zoj 2107 : Quoit Design

Quoit Design

Time Limit: 5 Seconds      Memory Limit: 32768 KB

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.


Input

The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.


Output

For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.


Sample Input

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0


Sample Output

0.71
0.00
0.75



Author: CHEN, Yue
Source: Zhejiang Provincial Programming Contest 2004

算法:

题目意思:求离散点群中的最小距离点对。

思想:

计算几何,先用sort()对所有点排序,然后进行暴力遍历,中间进行优化,定义临时距离ltemp,若下一个小于ltemp,则更新ltemp,否则退出,因为后面的都不会小于ltemp。

 

代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const double inf=1e9;
struct node
{
    double x,y;
} Point[100001];
bool cmp(node A,node B)
{
    if(A.x!=B.x)
        return A.x<B.x;
    else
        return A.y<B.y;
}
int main()
{
    int n,i,j;
    double ans,ltemp;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;++i)
        {
            scanf("%lf%lf",&Point[i].x,&Point[i].y);
        }
        sort(Point,Point+n,cmp);
        ans=inf;
        for(i=0;i<n-1;++i)
        {
            ltemp=inf;
            for(j=i+1;j<n;++j)
            {
                double l=(Point[i].x-Point[j].x)*(Point[i].x-Point[j].x)+(Point[i].y-Point[j].y)*(Point[i].y-Point[j].y);
                if(l<ltemp)
                {
                    ltemp=l;
                }
                else
                    break;
            }
            ans=min(ltemp,ans);
        }

        printf("%.2lf\n",sqrt(ans)/2);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值