poj2532(BIT)

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39677 Accepted: 17231

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1

0

//题目大意:给你一组坐标,其中当相邻两个的纵坐标不等时,按y坐标升序排列 ,相等时x大的在后。
//每个点都有一个水平值;一个点的水平值就是位于该横坐标左边纵坐标右边点的个数。求这n各点的水平值;
//解题思路:由于y的值是单调不递减的。所以对于点(x,y)只需考虑比x小的点的个数就是答案啦。
//由于n<=15000,x,y<=32000;暴力解决的话估计会超时;这题利用树状数组的话轻松a掉; 
#include<cstdio>
#include<cstring>
#define M 32005
long long  s[32050],bit[32050],n;
long long sum(int i)
{
	long long ans=0;
	while(i>0)
	{
		ans+=bit[i];    //统计比i小的个数 
		i-=i&(-i);
	}
	return ans;
}
void insert(int i,int x)
{
	while(i<=M)
	{
		bit[i]+=x;      //给比i大的数加1;即位于i的右边 
		i+=i&(-i);
	}
}
int main()
{
	    int i,j,x,y;
		memset(s,0,sizeof(s));
		memset(bit,0,sizeof(bit));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&x,&y);
			x+=1;              //由于书状数组从1开始算的;所以对于所有的i加1
			                   //以避免x==0情况 
			s[sum(x)]++;
			insert(x,1);
		}
		for(i=0;i<n;i++) printf("%lld\n",s[i]);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值