[C++] PAT 1144 The Missing Number (20分)

在这里插入图片描述

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

题解:

直接用map对每一个输入数字计数,之后从i=1开始遍历map,如果map[i] == 0,直接输出,停止循环

在#include <iostream>
#include <map>

using namespace std;

int n;
map<int,int> mp;

int main(){
	
	cin >> n;

	int temp;
	for(int i=0;i<n;i++){
		cin >> temp;
		mp[temp]++;
	}

	for(int i=1;;i++){

		if(mp[i]==0){
			cout << i;
			break;
		}
		
	}

	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值