HDU4961Boring Sum(在线更新方法)

Boring Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 446    Accepted Submission(s): 227


Problem Description
Number theory is interesting, while this problem is boring.

Here is the problem. Given an integer sequence a 1, a 2, …, a n, let S(i) = {j|1<=j<i, and a j is a multiple of a i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a f(i). Similarly, let T(i) = {j|i<j<=n, and a j is a multiple of a i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c i as a g(i). The boring sum of this sequence is defined as b 1 * c 1 + b 2 * c 2 + … + b n * c n.

Given an integer sequence, your task is to calculate its boring sum.

Input
The input contains multiple test cases.

Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a 1, a 2, …, a n (1<= a i<=100000).

The input is terminated by n = 0.

Output
Output the answer in a line.

Sample Input
  
  
5 1 4 2 3 9 0

Sample Output
  
  
136
Hint
In the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.

Author
SYSU

Source
 题意:给你一个数组,让你生成两个新的数组,A要求每个数如果能在它的前面找个最近的一个是它倍数的数,那就变成那个数,否则是自己,C是往后找,最后每对应的b,c相乘之和。
#include<stdio.h>
#include<string.h>

__int64 fact[100005][129],k[100005];
void setprim()
{
    memset(k,0,sizeof(k));
    for(__int64 i=1;i<=100000;i++)
    {
        for(__int64 j=i;j<=100000;j+=i)
        {
            fact[j][++k[j]]=i;
        }
    }
}
 __int64 a[100005],b[100005],c[100005],index[100005];
int main()
{
    setprim();
    __int64 i,j,sum,n;
    while(scanf("%I64d",&n)>0&&n)
    {
        for( i=1;i<=n;i++)
            scanf("%I64d",&a[i]);
        memset(index,0,sizeof(index));
        for(i=1;i<=n;i++)
        {
            if(index[a[i]])b[i]=a[index[a[i]]];
            else b[i]=a[i];
            for(j=1;j<=k[a[i]];j++)
            index[fact[a[i]][j]]=i;
        }
        sum=0;
        memset(index,0,sizeof(index));
        for(i=n;i>=1;i--)
        {
            if(index[a[i]])c[i]=a[index[a[i]]];
            else c[i]=a[i];
            for(j=1;j<=k[a[i]];j++)
            index[fact[a[i]][j]]=i;
        }
        for( i=1;i<=n;i++)
        sum+=b[i]*c[i];
        printf("%I64d\n",sum);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值