HDU4968Improving the GPA(分组背包)

Improving the GPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 283    Accepted Submission(s): 232


Problem Description
Xueba: Using the 4-Point Scale, my GPA is 4.0.

In fact, the AVERAGE SCORE of Xueba is calculated by the following formula:
AVERAGE SCORE = ∑(Wi * SCOREi) / ∑(Wi) 1<=i<=N

where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.

To simplify the problem, we assume that the credit of each course is 1. In this way, the AVERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.

In SYSU, the university usually uses the AVERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There are 2 ways of transforming each score to 4-Point Scale. Here is one of them.


The student’s average GPA in the 4-Point Scale is calculated as follows:
GPA = ∑(GPAi) / N

So given one student’s AVERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale.

Input
The input begins with a line containing an integer T (1 < T < 500), which denotes the number of test cases. The next T lines each contain two integers AVGSCORE, N (60 <= AVGSCORE <= 100, 1 <= N <= 10).

Output
For each test case, you should display the minimum and maximum value of the GPA in the 4-Point Scale in one line, accurate up to 4 decimal places. There is a space between two values.

Sample Input
  
  
4 75 1 75 2 75 3 75 10

Sample Output
  
  
3.0000 3.0000 2.7500 3.0000 2.6667 3.1667 2.4000 3.2000
Hint
In the third case, there are many possible ways to calculate the minimum value of the GPA in the 4-Point Scale. For example, Scores 78 74 73 GPA = (3.0 + 2.5 + 2.5) / 3 = 2.6667 Scores 79 78 68 GPA = (3.0 + 3.0 + 2.0) / 3 = 2.6667 Scores 84 74 67 GPA = (3.5 + 2.5 + 2.0) / 3 = 2.6667 Scores 100 64 61 GPA = (4.0 + 2.0 + 2.0) / 3 = 2.6667

Author
SYSU

Source
题意:给一个n个人的平均数AVG,问计算出最小的GPA和最大的GPA。
解题:把总分数算出,就用分组背包进行DP,每个分数组合满足恰好的情况。
#include<stdio.h>
#define inf 99999999
int main()
{
    double dp_max[11][1005],dp_min[11][1005];
    int t,n,AVG,sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&AVG,&n);
        sum=AVG*n;
        for(int j=0;j<=n;j++)
        for(int i=0;i<=sum;i++)
        dp_max[j][i]=-1,dp_min[j][i]=inf;

        dp_min[0][0]=dp_max[0][0]=0;
        for(int i=1;i<=n;i++)
        for(int s=sum;s>=60;s--)
        for(int j=60;j<=100&&j<=s;j++)
        {
             if(j<70)
            {
                if(dp_max[i][s]<dp_max[i-1][s-j]+2.0&&dp_max[i-1][s-j]!=-1)
                    dp_max[i][s]=dp_max[i-1][s-j]+2.0;
                if(dp_min[i][s]>dp_min[i-1][s-j]+2.0)
                    dp_min[i][s]=dp_min[i-1][s-j]+2.0;
            }
            else if(j<75)
            {
                if(dp_max[i][s]<dp_max[i-1][s-j]+2.5&&dp_max[i-1][s-j]!=-1)
                    dp_max[i][s]=dp_max[i-1][s-j]+2.5;
                if(dp_min[i][s]>dp_min[i-1][s-j]+2.5)
                    dp_min[i][s]=dp_min[i-1][s-j]+2.5;
            }
            else if(j<80)
            {
                if(dp_max[i][s]<dp_max[i-1][s-j]+3.0&&dp_max[i-1][s-j]!=-1)
                    dp_max[i][s]=dp_max[i-1][s-j]+3.0;
                if(dp_min[i][s]>dp_min[i-1][s-j]+3.0)
                    dp_min[i][s]=dp_min[i-1][s-j]+3.0;
            }
            else if(j<85)
            {
               if(dp_max[i][s]<dp_max[i-1][s-j]+3.5&&dp_max[i-1][s-j]!=-1)
                    dp_max[i][s]=dp_max[i-1][s-j]+3.5;
                if(dp_min[i][s]>dp_min[i-1][s-j]+3.5)
                    dp_min[i][s]=dp_min[i-1][s-j]+3.5;
            }
            else
            {
                if(dp_max[i][s]<dp_max[i-1][s-j]+4.0&&dp_max[i-1][s-j]!=-1)
                    dp_max[i][s]=dp_max[i-1][s-j]+4.0;
                if(dp_min[i][s]>dp_min[i-1][s-j]+4.0)
                    dp_min[i][s]=dp_min[i-1][s-j]+4.0;
            }
        }
        printf("%.4lf %.4lf\n",dp_min[n][sum]/n,dp_max[n][sum]/n);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值