poj 1330 Nearest Common Ancestors (树链剖分版LCA)

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:
poj 1330
In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge –the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

题意

题目给出多组数据,每组数据包含一棵节点数为N、边总数为N-1的树,以及两个节点(没错每组只有一个询问),要求这两个节点的LCA。

题解

这题实在是太裸了,单纯想重温一下如何打树链剖分和LCA练手用。不过它虽然简单但还是有需要注意的地方:树的根节点是不固定的,需要找到一个入度为0的点作为根。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 10005;

struct Edge {
    int v, next;
} edge[2 * N];

bool vis[N];
int T, n, a, b;
int num, head[N];
int indexx, dep[N], fa[N], son[N], siz[N], top[N], tag[N];

void zero() {
    num = 0, indexx = 0;
    memset(fa, 0, sizeof(fa));
    memset(son, -1, sizeof(son));
    memset(vis, 0, sizeof(vis));
    memset(siz, 0, sizeof(siz));
    memset(dep, 0, sizeof(dep));
    memset(head, 0, sizeof(head));
}

void add(int u, int v) {
    num ++;
    edge[num].v = v;
    edge[num].next = head[u];
    head[u] = num;
}

void dfs1(int u, int f, int d) {
    fa[u] = f;
    dep[u] = d;
    siz[u] = 1;
    for(int i = head[u]; i; i = edge[i].next) {
        int v = edge[i].v;
        if(v == f) continue;
        dfs1(v, u, d + 1);
        siz[u] += siz[v];
        if(son[u] == -1 || siz[son[u]] < siz[v])
            son[u] = v;
    }
}

void dfs2(int u, int tp) {
    top[u] = tp;
    tag[u] = ++ indexx;
    if(son[u] == -1) return ;
    dfs2(son[u], tp);
    for(int i = head[u]; i; i = edge[i].next) {
        int v = edge[i].v;
        if(v == son[u] || v == fa[u]) continue;
        dfs2(v, v);
    }
}

int query(int a, int b) {
    while(1) {
        if(top[a] == top[b]) {
            if(dep[a] < dep[b]) return a;
            return b;
        }
        else if(dep[top[a]] >= dep[top[b]])
            a = fa[top[a]];
        else b = fa[top[b]];
    }
}

int main() {
    scanf("%d", &T);
    while(T --) {
        zero();
        scanf("%d", &n);
        for(int i = 1; i < n; i ++) {
            int u, v;
            scanf("%d %d", &u, &v);
            vis[v] = 1;
            add(u, v);
            add(v, u);
        }
        int r;
        for(int i = 1; i <= n; i ++)
            if(! vis[i]) r = i;
        scanf("%d %d", &a, &b);
        dfs1(r, 0, 1); dfs2(r, 1);
        printf("%d\n", query(a, b));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值