hdu4611 Balls Rearrangement

44 篇文章 0 订阅

Balls Rearrangement

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1682 Accepted Submission(s): 634


Problem Description
  Bob has N balls and A boxes. He numbers the balls from 0 to N-1, and numbers the boxes from 0 to A-1. To find the balls easily, he puts the ball numbered x into the box numbered a if x = a mod A. Some day Bob buys B new boxes, and he wants to rearrange the balls from the old boxes to the new boxes. The new boxes are numbered from 0 to B-1. After the rearrangement, the ball numbered x should be in the box number b if x = b mod B.
  This work may be very boring, so he wants to know the cost before the rearrangement. If he moves a ball from the old box numbered a to the new box numbered b, the cost he considered would be |a-b|. The total cost is the sum of the cost to move every ball, and it is what Bob is interested in now.

Input
  The first line of the input is an integer T, the number of test cases.(0<T<=50)
  Then T test case followed. The only line of each test case are three integers N, A and B.(1<=N<=1000000000, 1<=A,B<=100000).

Output
  For each test case, output the total cost.

Sample Input
  
  
3 1000000000 1 1 8 2 4 11 5 3

Sample Output
  
  
0 8 16

Source

Recommend
zhuyuanchen520
唉,比赛的时候,一直想通过推出公式来,纠结在起过一个周期时,找到规律,其实,我们只要把有统一差值的一起算,不是统一差值的下次再算就已经很快了啊!
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
__int64 gcd(__int64 a,__int64 b)
{
    if(a==0)return b;
    return gcd(b%a,a);
}
__int64 solve(__int64 n,__int64 a,__int64 b)
{
    __int64 sum=0,k1=0,k2=0,i=0,temp;
    while(i<n)
    {
        temp=min(a-k1,b-k2);
        i+=temp,sum+=temp*fabs(k1-k2);
        if(i>n)
        sum-=(i-n)*fabs(k1-k2);
        k1=(k1+temp)%a,k2=(k2+temp)%b;
    }
    return sum;
}
int main()
{
    int tcase;
    __int64 n,m,a,b;
    scanf("%d",&tcase);
    while(tcase--)
    {
        scanf("%I64d%I64d%I64d",&n,&a,&b);
        m=a*b/gcd(a,b);
        if(n<m)
        {
            printf("%I64d\n",solve(n,a,b));
        }
        else
            printf("%I64d\n",n/m*solve(m,a,b)+solve(n%m,a,b));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值