hdu4619 Warm up 2 二分图 最大匹配

10 篇文章 0 订阅

Warm up 2

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1325 Accepted Submission(s): 583


Problem Description
  Some 1×2 dominoes are placed on a plane. Each dominoe is placed either horizontally or vertically. It's guaranteed the dominoes in the same direction are not overlapped, but horizontal and vertical dominoes may overlap with each other. You task is to remove some dominoes, so that the remaining dominoes do not overlap with each other. Now, tell me the maximum number of dominoes left on the board.

Input
  There are multiple input cases.
  The first line of each case are 2 integers: n(1 <= n <= 1000), m(1 <= m <= 1000), indicating the number of horizontal and vertical dominoes.
Then n lines follow, each line contains 2 integers x (0 <= x <= 100) and y (0 <= y <= 100), indicating the position of a horizontal dominoe. The dominoe occupies the grids of (x, y) and (x + 1, y).
  Then m lines follow, each line contains 2 integers x (0 <= x <= 100) and y (0 <= y <= 100), indicating the position of a horizontal dominoe. The dominoe occupies the grids of (x, y) and (x, y + 1).
  Input ends with n = 0 and m = 0.

Output
  For each test case, output the maximum number of remaining dominoes in a line.

Sample Input
  
  
2 3 0 0 0 3 0 1 1 1 1 3 4 5 0 1 0 2 3 1 2 2 0 0 1 0 2 0 4 1 3 2 0 0

Sample Output
  
  
4 6

Source

Recommend
zhuyuanchen520
最大二分匹配,其实,我们把横着的和竖着的分成两个点集,如果两个点相交,就连一条边,我们找到最大匹配,然后,用总点数减去匹配的,就是孤立的点了,这样,就可以得出答案了!
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
#define MAXN 1005
struct node {
    int x,y;
}p[MAXN][2];
bool g[MAXN][MAXN];
int uN,vN;
int xM[MAXN],yM[MAXN];
bool chk[MAXN];
bool can(int i,int j)
{
    if(p[i][0].x==p[j][1].x&&(p[j][1].y+1==p[i][0].y))
    return true;
    if(p[i][0].x==p[j][1].x&&(p[j][1].y-p[i][0].y==0))
    return true;
    if(p[i][0].x+1==p[j][1].x&&(p[j][1].y+1==p[i][0].y))
    return true;
    if(p[i][0].x+1==p[j][1].x&&(p[j][1].y-p[i][0].y==0))
    return true;
    return false;
}
bool SearchPath(int u)
{
    int v;
    for(v=0;v<vN;v++)
    if(g[u][v]&&!chk[v])
    {
        chk[v]=true;
        if(yM[v]==-1||SearchPath(yM[v]))
        {
            yM[v]=u;xM[u]=v;
            return true;
        }
    }
    return false;
}
int MaxMatch()
{
    int u,ret=0;
    memset(xM,-1,sizeof(xM));
    memset(yM,-1,sizeof(yM));
    for(u=0;u<uN;u++)
    if(xM[u]==-1)
    {
        memset(chk,false,sizeof(chk));
        if(SearchPath(u))ret++;
    }
    return ret;
}
int main()
{
    int n,m,i,x,y,j;
    while(scanf("%d%d",&n,&m)!=EOF&&n+m)
    {
       memset(g,false,sizeof(g));
        for(i=0;i<n;i++)
            scanf("%d%d",&p[i][0].x,&p[i][0].y);
        for(i=0;i<m;i++)
            scanf("%d%d",&p[i][1].x,&p[i][1].y);
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            if(can(i,j))
            {
                g[i][j]=true;
            }
        uN=n,vN=m;
        printf("%d\n",n+m-MaxMatch());
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值