HDU 4619 (二分图匹配 最大独立集)

Warm up 2

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2052    Accepted Submission(s): 938


Problem Description
  Some 1×2 dominoes are placed on a plane. Each dominoe is placed either horizontally or vertically. It's guaranteed the dominoes in the same direction are not overlapped, but horizontal and vertical dominoes may overlap with each other. You task is to remove some dominoes, so that the remaining dominoes do not overlap with each other. Now, tell me the maximum number of dominoes left on the board.
 

Input
  There are multiple input cases.
  The first line of each case are 2 integers: n(1 <= n <= 1000), m(1 <= m <= 1000), indicating the number of horizontal and vertical dominoes.
Then n lines follow, each line contains 2 integers x (0 <= x <= 100) and y (0 <= y <= 100), indicating the position of a horizontal dominoe. The dominoe occupies the grids of (x, y) and (x + 1, y).
  Then m lines follow, each line contains 2 integers x (0 <= x <= 100) and y (0 <= y <= 100), indicating the position of a horizontal dominoe. The dominoe occupies the grids of (x, y) and (x, y + 1).
  Input ends with n = 0 and m = 0.
 

Output
  For each test case, output the maximum number of remaining dominoes in a line.
 

Sample Input
  
  
2 3 0 0 0 3 0 1 1 1 1 3 4 5 0 1 0 2 3 1 2 2 0 0 1 0 2 0 4 1 3 2 0 0
 

Sample Output
  
  
4 6
 


题意是给你n个横向的骨牌和m个纵向的骨牌,保证各自方向的骨牌不相交,问最少拿掉多少张骨牌使得所有的骨牌没有相交的情况.骨牌的长度是1.

用到了二分图的一个性质,二分图的最大独立集=所有的节点数-二分图最大匹配.

正好横向纵向两类点,如果相交就连边,然后就求个最大匹配就好了.

#include <bits/stdc++.h>
using namespace std;
#define maxn 2111
#define maxm 2111111

int n, m;
int a[maxn][2], b[maxn][2];
struct node {
    int from, to, next;
}edge[maxm];
int head[maxn];
int cnt;

void add_edge (int from , int to) {
    edge[cnt].from = from, edge[cnt].to = to, edge[cnt].next = head[from], head[from] = cnt++;
}

bool jiao (int i, int j) {
    if (a[i][0] == b[j][0] && a[i][1] == b[j][1])
        return 1;
    if (a[i][0]+1 == b[j][0] && a[i][1] == b[j][1])
        return 1;
    if (a[i][0] == b[j][0] && a[i][1] == b[j][1]+1)
        return 1;
    if (a[i][0]+1 == b[j][0] && a[i][1] == b[j][1]+1)
        return 1;
    return 0;
}


int pre[maxn], vis[maxn];
bool dfs (int u) {
    for (int i = head[u]; i != -1; i = edge[i].next) {
        int v = edge[i].to;
        if (!vis[v]) {
            vis[v] = 1;
            if (pre[v] == -1 || dfs (pre[v])) {
                pre[v] = u;
                return 1;
            }
        }
    }
    return 0;
}

int hungry () {
    int ans = 0;
    memset (pre, -1, sizeof pre);
    for (int i = 1; i <= n; i++) {
        memset (vis, 0, sizeof vis);
        if (dfs (i))
            ans++;
    }
    return ans;
}

int main () {
    //freopen ("in", "r", stdin);
    ios::sync_with_stdio (0);
    while (cin >> n >> m && n+m) {
        cnt = 0;
        memset (head, -1, sizeof head);
        for (int i = 1; i <= n; i++) {
            cin >> a[i][0] >> a[i][1];
        }
        for (int j = 1+n; j <= n+m; j++) {
            cin >> b[j][0] >> b[j][1];
            for (int i = 1; i <= n; i++) {
                if (jiao (i, j)) {
                    add_edge (i, j);
                    add_edge (j, i);
                }
            }
        }
        cout << n+m-hungry () << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值