poj1740 A New Stone Game

67 篇文章 1 订阅
A New Stone Game
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4509 Accepted: 2447

Description

Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.

Output

For each test case, if Alice win the game,output 1,otherwise output 0.

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0
1.如果只有一堆,一定必胜!2,如果,是xx yy,这种情况一定是败的,因为,不论你怎么做,另外的一个人,总是有方法,和你做的是相反的,最终一定会败,3.如果,有不相同的,一定能胜,为什么呢,你想,如果,这个人能把这种情况转化成2的情况给另外一个人,那么他不就必胜了么,事实上,也确实存在,因为,每个数从小到大的排了序之后,就可以用最大的一堆来平衡所有的堆,因为,所有堆的高度差相加起来一定比最高的那个要小啊,只是对于n是奇数的话,就把这个堆平衡完之后剩下的,全部都去掉就可以了!
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define M 1050
int pri[M];
int main()
{
    int n,i,ans;
    while(scanf("%d",&n)!=EOF&&n){
        for(i=0;i<n;i++){
            scanf("%d",&pri[i]);
        }
        sort(pri,pri+n);
        if(n&1){
            printf("1\n");
        }
        else {
            for(ans=0,i=0;i<n-1;i=i+2){
                if(pri[i]!=pri[i+1]){
                    ans=1;
                    break;
                }
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值