hdu 2602 Bone Collector

108 篇文章 0 订阅

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input

     
     
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

     
     
14
就是01背包
真接上代码
#include<stdio.h>

int c[3500],w[3500],f[13000];
int main()
{
	int i,j,k,n,v,m,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=0;i<=m;i++)
			f[i]=0;
		for(i=0;i<n;i++)
			scanf("%d",w+i);
		for(i=0;i<n;i++)
			scanf("%d",c+i);
		for (i = 0; i < n; ++i)
		{
			for (v = m; v >= c[i]; --v) //注意这里的V是从大到小c[i]可优化为bound,bound = max {V - sum c[i,...n],c[i]}
			{
				f[v] = (f[v] > f[v - c[i]] + w[i]?f[v] : f[v - c[i]] + w[i]);
			}
		}
		printf("%d\n",f[m]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值