hdu4546 So Easy! 矩阵乘法

44 篇文章 0 订阅
8 篇文章 0 订阅

So Easy!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 899 Accepted Submission(s): 244


Problem Description
  A sequence S n is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy!

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.

Output
  For each the case, output an integer S n.

Sample Input
  
  
2 3 1 2013 2 3 2 2013 2 2 1 2013

Sample Output
  
  
4 14 4

Source

Recommend
zhoujiaqi2010
这可一点都不so easy啊,注意取模的时候可能为负!
#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
__int64 mod;
struct matrix {
    __int64 a[2][2];
    matrix operator * (matrix num)const
    {
        int i,j,k;
        matrix temp;
        for(i=0;i<2;i++)
        {
            for(j=0;j<2;j++)
            {
                temp.a[i][j]=0;
                for(k=0;k<2;k++)
                {
                    temp.a[i][j]+=a[i][k]*num.a[k][j]%mod;
                    temp.a[i][j]%=mod;
                }
            }
        }
        return temp;

    }
};
int main()
{
   __int64 a,b,n,m;
   matrix start,original,temp;
   while(scanf("%I64d%I64d%I64d%I64d",&a,&b,&n,&m)!=EOF)
   {
       mod=m;

      if(n==1)
      {
          printf("%I64d\n",2*(a%m)%m);
          continue;
      }
      else if(n==2)
      {
          printf("%I64d\n",(2*(a%m)*(a%m)+2*(b%m)%m));
          continue;
      }
      n=n-2;
      a=a%m,b=b%m;
      start.a[0][0]=2*a%m;
      start.a[0][1]=1;
      start.a[1][0]=(b-a*a%m+m)%m;
      start.a[1][1]=0;
      original.a[0][0]=1,original.a[1][1]=1;
      original.a[1][0]=0,original.a[0][1]=0;
      temp.a[0][0]=(2*a*a%m+2*b%m)%m;temp.a[0][1]=2*a%m;
      temp.a[1][0]=0,temp.a[1][1]=0;
      while(n)
      {
          if(n&1)
            original=original*start;
          n=n>>1;
          start=start*start;
      }
      temp=temp*original;
      printf("%I64d\n",temp.a[0][0]%m);

   }
    return 0;
}


对于HDU4546问题,还可以使用优先队列(Priority Queue)来解决。以下是使用优先队列的解法思路: 1. 首先,将数组a进行排序,以便后续处理。 2. 创建一个优先队列(最小堆),用于存储组合之和的候选值。 3. 初始化优先队列,将初始情况(即前0个数的组合之和)加入队列。 4. 开始从1到n遍历数组a的元素,对于每个元素a[i],将当前队列中的所有候选值取出,分别加上a[i],然后再将加和的结果作为新的候选值加入队列。 5. 重复步骤4直到遍历完所有元素。 6. 当队列的大小超过k时,将队列中的最小值弹出。 7. 最后,队列中的所有候选值之和即为前k小的组合之和。 以下是使用优先队列解决HDU4546问题的代码示例: ```cpp #include <iostream> #include <vector> #include <queue> #include <functional> using namespace std; int main() { int n, k; cin >> n >> k; vector<int> a(n); for (int i = 0; i < n; i++) { cin >> a[i]; } sort(a.begin(), a.end()); // 对数组a进行排序 priority_queue<long long, vector<long long>, greater<long long>> pq; // 最小堆 pq.push(0); // 初始情况,前0个数的组合之和为0 for (int i = 0; i < n; i++) { long long num = pq.top(); // 取出当前队列中的最小值 pq.pop(); for (int j = i + 1; j <= n; j++) { pq.push(num + a[i]); // 将所有加和结果作为新的候选值加入队列 num += a[i]; } if (pq.size() > k) { pq.pop(); // 当队列大小超过k时,弹出最小值 } } long long sum = 0; while (!pq.empty()) { sum += pq.top(); // 求队列中所有候选值之和 pq.pop(); } cout << sum << endl; return 0; } ``` 使用优先队列的方法可以有效地找到前k小的组合之和,时间复杂度为O(nklog(k))。希望这个解法对你有所帮助!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值