Little Tiger vs. Deep Monkey

A crowd of little animals is visiting a mysterious laboratory �C The Deep Lab of SYSU.

“Are you surprised by the STS (speech to speech) technology of Microsoft Research and the cat face recognition project of Google and academia? Are you curious about what technology is behind those fantastic demos?” asks the director of the Deep Lab. “Deep learning, deep learning!” Little Tiger raises his hand briskly. “Yes, clever boy, that’s deep learning (深度学习/深度神经网络)”, says the director. “However, they are only ‘a piece of cake’. I won’t tell you a top secret that our lab has invented a Deep Monkey (深猴) with more advanced technology. And that guy is as smart as human!”

“Nani ?!” Little Tiger doubts about that as he is the smartest kid in his kindergarten; even so, he is not as smart as human, “how can a monkey be smarter than me? I will challenge him.”

To verify their research achievement, the researchers of the Deep Lab are going to host an intelligence test for Little Tiger and Deep Monkey.

The test is composed of N binary choice questions. And different questions may have different scores according to their difficulties. One can get the corresponding score for a question if he chooses the correct answer; otherwise, he gets nothing. The overall score is counted as the sum of scores one gets from each question. The one with a larger overall score wins; tie happens when they get the same score.

Little Tiger assumes that Deep Monkey will choose the answer randomly as he doesn’t believe the monkey is smart. Now, Little Tiger is wondering “what score should I get at least so that I will not lose in the contest with probability of at least P? ”. As little tiger is a really smart guy, he can evaluate the answer quickly.

You, Deep Monkey, can you work it out? Show your power!�
Input
The first line of input contains a single integer T (1 ≤ T ≤ 10) indicating the number of test cases. Then T test cases follow.

Each test case is composed of two lines. The first line has two numbers N and P separated by a blank. N is an integer, satisfying 1 ≤ N ≤ 40. P is a floating number with at most 3 digits after the decimal point, and is in the range of 0,1  0,1. The second line has N numbers separated by blanks, which are the scores of each question. The score of each questions is an integer and in the range of 1,1000  1,1000
Output
For each test case, output only a single line with the answer.
Sample Input
1
3 0.5
1 2 3
Sample Output

3

给你n个问题,分别给你这些问题的分数,问你至少得到少分才能保证在概率至少为p的情况子保证不输(做题的人都很智障,只有正确和错误两种结果,而且两者概率一样大),

思路:刚开始以为是水题,没怎么读题就写了,可是wa了还几次,后来仔细读了一下题,是一道简单的dp题,dp出做出所有题所有得分情况的概率,这些概率之和一定是1,然后从小枚举分数,逐步求和,当该和大于所给概率时,输出分数即可

ac代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
using namespace std;
double dp[50][44001];
int a[50],b[50];
int main()
{
   int x,y,t;
   double h;
   cin>>t;
   while(t--)
   {
     cin>>x>>h;
     int sum=0;
     for(int i=1;i<=x;i++)
     {
         scanf("%d",&a[i]);
         sum+=a[i];
         b[i]=sum;
     }
     memset(dp,0,sizeof(dp));
      dp[0][0]=1;
      for(int i=1;i<=x;i++)
      {
          for(int j=0;j<=b[i];j++)
          {
              dp[i][j]+=dp[i-1][j]*0.5;
              if(j>=a[i])
              dp[i][j]+=dp[i-1][j-a[i]]*0.5;
          }
      }
      double g=0;
      for(int i=0;i<=sum;i++)
      {
         g+=dp[x][i];
         if(g>=h)
         {
             printf("%d\n",i);
             break;
         }
      }
   }
   return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值