HDU 4287 (13.08.17)

Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
  
  
1 3 5 46 64448 74 go in night might gn
 

Sample Output
  
  
3 2 0

题意与思路:

输入N个按键序列, 再输入M个单词, 要求我们对M个单词进行检索, 求出其按键序列

然后统计, N个按键序列每个分别出现了几次

错误点: 由于不注意严谨, 以为少写一个break没事, 导致超时~

我有两份代码, 一份是错误的, 还没找出错误来, 一份已AC;

AC代码:

#include<stdio.h>
#include<string.h>

int t[26] = {2, 2, 2, 3, 3, 3, 4, 4, 4, 5, 5, 5, 6, 6, 6, 7, 7, 7, 7, 8, 8, 8, 9, 9, 9, 9};

int T, N, M;

int ans[5555];
char num[5555][10];
char word[5555][10];

void getans(char *p) {
    int i, len;
    int pos = 0;
    char t_num[10];
    len = strlen(p);
    for(i = 0; i < len; i++)
        t_num[pos++] = t[p[i]-'a'] + '0';
    t_num[pos] = '\0';
    for(i = 0; i < N; i++)
        if(strcmp(t_num, num[i]) == 0) {
            ans[i]++;
            break;
        }
}

int main() {
    scanf("%d", &T);
    while(T--) {
        int i;
        scanf("%d %d", &N, &M);

        getchar();

        memset(ans, 0, sizeof(ans));
        for(i = 0; i < N; i++)
            gets(num[i]);
        for(i = 0; i < M; i++)
            gets(word[i]);

        for(i = 0; i < M; i++)
            getans(word[i]);

        for(i = 0; i < N; i++)
            printf("%d\n", ans[i]);
    }
    return 0;
}


wrong代码:

#include<stdio.h>
#include<string.h>

int T, N, M;

char num[5555][10];
char word[5555][10];
int ans[5555];

char t[10][10];

void getans(char *p) {
    int i, j, k, pos = 0;
    char t_num[10];
    int len1, len2;
    len1 = strlen(p);
    for(i = 0; i < len1; i++) {
        for(j = 2; j < 10; j++) {
            len2 = strlen(t[j]);
            for(k = 0; k < len2; k++) {
                if(t[j][k] == p[i])
                    t_num[pos++] = j;
            }
        }
    }

    t_num[pos] = '\0';
    for(i = 0; i < N; i++) {
        if(strcmp(t_num, num[i]) == 0)
            ans[i]++;
    }
}

int main() {
    scanf("%d", &T);

    while(T--) {
        int i;
        scanf("%d%d", &N, &M);

        memset(ans, 0, sizeof(ans));
    	strcpy(t[2], "abc");
    	strcpy(t[3], "def");
    	strcpy(t[4], "ghi");
    	strcpy(t[5], "jkl");
    	strcpy(t[6], "mno");
    	strcpy(t[7], "pqrs");
    	strcpy(t[8], "tuv");
    	strcpy(t[9], "wxyz");

        for(i = 0; i < N; i++)
            gets(num[i]);
        for(i = 0; i < M; i++)
            gets(word[i]);

        for(i = 0; i < M; i++)
            getans(word[i]);

        for(i = 0; i < N; i++)
            printf("%d\n", ans[i]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值