2012 ACM/ICPC Asia Regional Tianjin 1010 Intelligent IME

                     1010. Intelligent IME
Description
We all use cell phone today. And we must be familiar with the intelligent English
input method on the cell phone. To be specific, the number buttons may correspond to
some English letters respectively, as shown below:
2 : a, b, c 3 : d, e, f 4 : g, h, i 5 : j, k, l 6 : m, n, o
7 : p, q, r, s 8 : t, u, v 9 : w, x, y, z
When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the
input method will choose from an embedded dictionary, all words matching the input
number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a
dictionary, how many words in it match some input number sequences?
Input
First is an integer T, indicating the number of test cases. Then T block follows,
each of which is formatted like this:
Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of
input number sequences and the number of words in the dictionary, respectively. Then
comes N lines, each line contains a number sequence, consisting of no more than 6
digits. Then comes M lines, each line contains a letter string, consisting of no more
than 6 lower letters. It is guaranteed that there are neither duplicated number
sequences nor duplicated words.
Output
For each input block, output N integers, indicating how many words in the
dictionary match the corresponding number sequence, each integer per line.
Sample Input
13
5
46
64448
74
go
in
night
might
gn
第37 届ACM-ICPC 亚洲天津赛区网络赛试题(2012 年9 月9 日)
17
Sample Output
3

2

0

 

题目大意:就是给出数字和字符串,看每一行数字能够对应几个字符串

思路:呜呜,我这菜鸟太菜了~~反过来的映射那么简单~~就没想到

program:


 #include <iostream>
 #include <cstdio>
 #include <cstring>
 #include <map>
 
 using namespace std;
 
 const int X = 5005;
 
 int n,m;
 int use[X];
 
 int a[] = {2,2,2,3,3,3,4,4,4,5,5,5,6,6,6,7,7,7,7,8,8,8,9,9,9,9};
 
 map<int,int> ma;
 char s[10];
 
 int main(){
     freopen("sum.in","r",stdin);
     int ncase;
     scanf("%d",&ncase);
     while(ncase--){
         int x;
         scanf("%d%d",&n,&m);
         ma.clear();
         memset(use,0,sizeof(use));
         for(int i=1;i<=n;i++){
             scanf("%d",&x);
             ma[x] = i;
         }
         int temp;
         for(int i=0;i<m;i++){
             scanf("%s",s);
             temp = 0;
             for(int j=0;s[j];j++)
                 temp = temp*10+a[s[j]-'a'];  //上面的那个数组是巧妙还原成数字较为简单
             use[ma[temp]]++;
         }
         for(int i=1;i<=n;i++)
             printf("%d\n",use[i]);
     }
     return 0;
 }

 

转载出处:http://www.cnblogs.com/yejinru/archive/2012/09/09/2677665.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值