省赛第一次选拔赛K题

题目描述

We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?

输入

First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.

输出

For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.

样例输入

1
3 5
46
64448
74
go
in
night
might
gn

样例输出

3
2
0
#include<iostream>
#include<cstring>
#include<map>
using namespace std;
map< string, int > m1;
int main()
{
	int t,i,j;
	cin>>t;
	string str;
	string num[5000];
	while(t--)
	{
		int n,m;
		cin>>n>>m;
		for(i=0;i<n;i++)
		cin>>num[i];
		while(m--)
		{
			cin>>str;
			for(i=0;i<str.length();i++)
			{
				if(str[i]=='a'||str[i]=='b'||str[i]=='c') str[i]='2';
				else if(str[i]=='d'||str[i]=='e'||str[i]=='f') str[i]='3';
				else if(str[i]=='g'||str[i]=='h'||str[i]=='i') str[i]='4';
				else if(str[i]=='j'||str[i]=='k'||str[i]=='l') str[i]='5';
				else if(str[i]=='m'||str[i]=='n'||str[i]=='o') str[i]='6';
				else if(str[i]=='p'||str[i]=='q'||str[i]=='r'||str[i]=='s') str[i]='7';
				else if(str[i]=='t'||str[i]=='u'||str[i]=='v') str[i]='8';
				else if(str[i]=='w'||str[i]=='x'||str[i]=='y'||str[i]=='z') str[i]='9';
				m1[str]++;				
			}
		}
		for(i=0;i<n;i++)
		cout<<m1[num[i]]<<endl;
		m1.clear();
	}
	return 0;
}

代码属参考,非本人所写

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值