The Unique MST (POJ 1679)

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
#include <iostream>
#include <queue>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iomanip>
using namespace std;

struct Edge{
    int u, v, w;
}edges[10010];

int t, n, m, mst, cnt, flag;
int father[110], path[10010];

void makeSet(){
    for (int i = 1; i <= n; i++)
        father[i] = i;
}

int findSet(int x){
    if (father[x] != x)
        father[x] = findSet(father[x]);
    return father[x];
}

int cmp(Edge a, Edge b)
{
    return a.w < b.w;
}

void Kruskal(){ //true则表示mst不唯一;
    makeSet();
    sort(edges,edges + m, cmp);
    cnt = 0;
    mst = 0;
    for (int i = 0; i < m; i++)
    {
        int u = findSet(edges[i].u);
        int v = findSet(edges[i].v);
        if (u != v)
        {
            father[u] = v;
            path[cnt++] = i; //记录路径;
            mst += edges[i].w; //最小生成树的总权值;
        }
    }
    for (int k = 0; k < cnt; k++)
    { //枚举去掉每一条边;
        makeSet();
        int sum = 0; //sum用于记录新的生成树的总权值;
        int j = 0; //j用于记录新生成树的边的数量;
        for (int i = 0; i < m; i++)
        {
            if (i == path[k]) //不使用这一条边;
                continue;
            int u = findSet(edges[i].u);
            int v = findSet(edges[i].v);
            if (u != v)
            {
                father[u] = v;
                sum += edges[i].w;
                j++;
            }
        }
        if (j == n - 1 && sum == mst)
        { //能构成树,且为最小生成树;
            flag = 0;
            return;
        }
    }
}

int main(){
    cin >> t;
    while (t--)
    {
        cin >> n >> m;
        for (int i = 0; i < m; i++)
        {
            cin >> edges[i].u >> edges[i].v >> edges[i].w;
        }
        flag = 1;
        Kruskal();
        if (flag)
            cout << mst << endl;
        else
            cout << "Not Unique!" << endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值