[PAT (Advanced Level) ]1023. Have Fun with Numbers 解题文档

1023. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

分析:此题不能使用int能求解,明显越界。考虑到long也不是很好,因此采用string来存储数字。用vector来标记数量(也可以用静态数组,一样的)

难度不大。


C++代码如下。

#include<iostream>
#include<vector>
#include<string>
#include<strstream>
using namespace std;
vector<int> vec1,vec2;
string doubleResult;
string doubleNum(string str){
    string res="";
    int N=(int)str.size();
    int xxx=0;
    for(int i=0;i<N;i++){
        int t=(str[N-i-1])-48;
        vec1[t]++;
        int temp=((t*2)%10+xxx);
        vec2[temp]++;
        strstream ss;
        string strtemp;
        ss<<temp;
        ss>>strtemp;
        res=strtemp+res;
        if(t*2<10){
            xxx=0;
        }
        if(t*2>=10){
            xxx=1;
        }
    }
    if(xxx==1){
        res="1"+res;
    }
    return res;
}

string isFun(string str){
    for(int i=0;i<10;i++){//initial
        vec1.push_back(0);
        vec2.push_back(0);
    }
    doubleResult=doubleNum(str);
    for(int i=0;i<10;i++){
       if(vec1[i]!=vec2[i])
           return "No";
    }
    return "Yes";
}

int main(){
    string str;
    cin>>str;
    cout<<isFun(str)<<endl<<doubleResult;
}

测试点均通过。



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值