[PAT (Advanced Level) ]1009. Product of Polynomials 解题文档

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000. 

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place. 

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

分析:

此题看上去很简单。其实有很多需要注意的地方,比如系数为0的时候改怎么处理,采用什么样的东西来存储等等。笔者花了1个小时左右的时间才完全AC这道题。


C++代码如下。

#include<iostream>
#include<vector>
#include<iomanip>
using namespace std;

int main(){
    int N;
    cin>>N;
    vector<int> Aexponents,Bexponents,Resexponents;
    vector<double> Acoefficients,Bcoefficients,Rescoefficients;
    for(int i=0;i<N;i++){
        int temp1;
        cin>>temp1;
        Aexponents.push_back(temp1);
        double temp2;
        cin>>temp2;
        Acoefficients.push_back(temp2);
    }
    
    int M;
    cin>>M;
    for(int i=0;i<M;i++){
        int temp1;
        cin>>temp1;
        Bexponents.push_back(temp1);
        double temp2;
        cin>>temp2;
        Bcoefficients.push_back(temp2);
    }
    
    
    for(int i=0;i<N;i++){
        for(int j=0;j<M;j++){
            int exptemp=Aexponents[i]+Bexponents[j];
          // Resexponents[i*M+j]= ;
            double cofftemp= (double)Acoefficients[i]*(double)Bcoefficients[j];
            if(cofftemp==0) {break;
            };
            //cout<<Rescoefficients[i*M+j]<<endl;
            bool isExist=false;
            for(int k=0;k<Resexponents.size();k++){
                if(Resexponents[k]==exptemp){
                    Rescoefficients[k]+=cofftemp;
                    if(Rescoefficients[k]==0){//remove
                        std::vector<int>::iterator it = Resexponents.begin()+k;
                        Resexponents.erase(it);
                        std::vector<double>::iterator it1 = Rescoefficients.begin()+k;
                        Rescoefficients.erase(it1);
                        
                    }
                    isExist=true;
                }
            }
            if(!isExist){
                if(cofftemp!=0){
                Resexponents.push_back(exptemp);
                Rescoefficients.push_back(cofftemp);//
                }
//                else{
//                    Resexponents.push_back(0);
//                    Rescoefficients.push_back(0);//
//                }
            }
        }
    }
    cout<<Resexponents.size()<<" ";
    int NN=(int)Resexponents.size();
    if(NN==0){
        cout<<"0 0";
    }
    for(int i=0;i<NN;i++){
      //  cout<<NN;
        int big=-1000000;
        int big_index=-1;
        for(int j=0;j<(int)Resexponents.size();j++){
            if(big<Resexponents[j]){
                big=Resexponents[j];
                big_index=j;
            }
        }
        if(i==NN-1)
            cout<<Resexponents[big_index]<<" "<<fixed<<setprecision(1)<<Rescoefficients[big_index];
        else
            cout<<Resexponents[big_index]<<" "<<fixed<<setprecision(1)<<Rescoefficients[big_index]<<" ";
        std::vector<int>::iterator it = Resexponents.begin()+big_index;
        Resexponents.erase(it);
        std::vector<double>::iterator it1 = Rescoefficients.begin()+big_index;
        Rescoefficients.erase(it1);
        
    }
    return 0;
}

测试点全部通过。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值