【PAT】1009. Product of Polynomials (25)

题目描述

This time, you are supposed to find A*B where A and B are two polynomials.

翻译:这一次,你需要输出运算 A和B两个多项式的乘积。

INPUT FORMAT

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

翻译:每个测试文件包含一组测试数据。每组测试数据包括两行,每行包含一个多项式信息:K N1 aN1 N2 aN2 … NK aNK,K是该多项式的非零项个数,Ni和aNi (i=1, 2, …, K) 分别是指数和系数,数据规模为1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000

OUTPUT FORMAT

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

翻译:对于每组测试数据,你需要在一行内按照输入的格式输出A和B的乘积。注意每行末尾不能有多余的空格。请保留一位小数。


Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5


Sample Output

3 3 3.6 2 6.0 1 1.6


解题思路

定义一个结构体保存系数和指数,然后让A和B各项两两相乘用ans数组保存即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
struct term{
    int e;
    double c;
};
term a[1010],b[1010];
double ans[2010];
int ccount=0;
int main(){
    int N1,N2;
    scanf("%d",&N1);
    for(int j=0;j<N1;j++){
        scanf("%d%lf",&a[j].e,&a[j].c);
    }
    scanf("%d",&N2);
    for(int j=0;j<N2;j++){
        scanf("%d%lf",&b[j].e,&b[j].c);
    }   
    for(int i=0;i<N1;i++){
        for(int j=0;j<N2;j++){
            double Exp=a[i].c * b[j].c;
            int Coe=a[i].e + b[j].e;
            ans[Coe]+=Exp;
        }
    }
    for(int i=2000;i>=0;i--)if(ans[i])ccount++;
    printf("%d",ccount);
    for(int i=2000;i>=0;i--){
        if(ans[i]){
            printf(" %d %.1lf",i,ans[i]);
        }
    }
    printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值