HDU 3117 Fibonacci Numbers

题目链接 : HDU3117

Fibonacci Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1311    Accepted Submission(s): 549


Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number?
 


 

Input
For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”).

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
 


 

Sample Input
  
  
0 1 2 3 4 5 35 36 37 38 39 40 64 65
 


 

Sample Output
  
  
0 1 1 2 3 5 9227465 14930352 24157817 39088169 63245986 1023...4155 1061...7723 1716...7565
 


 

Source
 


 

Recommend
lcy
 

 

数学题  用通项和快速幂求最高4位

网上还有更神的做法。

 

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
using namespace std;


int fib[45];
void mult(int a[][2],int b[][2],int c[][2])
{
    int d[2][2]={0};
    for(int i=0;i<2;i++)
        for(int j=0;j<2;j++)
            for(int k=0;k<2;k++)
                d[i][j]=(d[i][j]+(a[i][k]*b[k][j])%10000)%10000;
    for(int i=0;i<2;i++)
        for(int j=0;j<2;j++)
            c[i][j]=d[i][j];
}
void pow_mat(int a[][2],int k)
{
    int ii[2][2]={0};
    for(int i=0;i<2;i++)
        ii[i][i]=1;
    while(k)
    {
        if(k%2) mult(a,ii,ii);
        k/=2;
        mult(a,a,a);
    }
    for(int i=0;i<2;i++)
        for(int j=0;j<2;j++)
            a[i][j]=ii[i][j];
}
double pow_sa(double fa,int k)
{
    double s=1.0,lim=1e20;
    while(k)
    {
        if(k&1)
        {
            s=s*fa;
            while(s>lim) s/=1000000000;
        }
        k>>=1;
        fa=fa*fa;
        while(fa>lim) fa/=1000000000;
    }
    return s;
}
int main()
{
 //   freopen("1.txt","r",stdin);
    int n;
    fib[1]=fib[2]=1;
    for(int i=3;i<40;i++)
        fib[i]=fib[i-1]+fib[i-2];
    double k=sqrt(5.0);
    while(scanf("%d",&n)==1)
    {
        if(n<40) printf("%d\n",fib[n]);
        else
        {
            int s[2][2]={1,1,1,0};
            pow_mat(s,n);
            int last=s[1][0];
            long double ans=k/5.0*(pow_sa((1+k)/2,n)-pow_sa((1-k)/2,n));
            while(ans>100000.0) ans/=10.0;
            int fir=(int)ans;
            printf("%d...%04d\n",fir/10,last);
        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值