UVa644 Immediate Decodability


  Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable



Miguel A. Revilla 
2000-01-17

这题大意就是给予n串的数字,然后要求判断是否可解码,即任意一串的数字是否包含与其他数字中,这题可用生成树来做,首先创建一个根节点,然后对于一串数字,若为0着标记为左节点,若为1则为右节点。同时通过记标明每串字符串各节点的位置以及终点的位置,在生成树时,若当前节点已经为其他节点的终点时,返回不可解码,若当前字符串的终点节点属于其他节点的一部分时,也返回不可解码,此外则返回可解码。

#include <iostream>
#include <cstring>
using namespace std;

const int N = 1000;

struct Node {
	bool sign;
	bool end;
	Node *left;
	Node *right;
}root,node[N];

char encoding[N];
int current = 0;
bool answer = true;

void initialize() {
	root.sign = false;
	root.end = false;
	root.left = NULL;
	root.right = NULL;
	memset(node,0,sizeof(node));
	memset(encoding,0,sizeof(encoding));
	current = 0;
	answer = true;
}

bool buildTree(char *encoding,int position,Node *parentNode) {
	if (parentNode->end) {
		return false;
	}
	if (!parentNode->left)
		parentNode->left = &node[current++];
	if (!parentNode->right)
		parentNode->right = &node[current++];
	if (!encoding[position]) {
		if (parentNode->sign) {
			return false;
		}
		else {
			parentNode->end = true;
			return true;
		}
	}
	parentNode->sign = true;

	if (encoding[position] == '0')
		return buildTree(encoding,position+1,parentNode->left);
	if (encoding[position] == '1')
		return buildTree(encoding,position+1,parentNode->right);
}

int main() {
	int Case = 1;
	initialize();
	while (cin >> encoding) {
		if (!strcmp(encoding,"9")) {
			if (answer)
				cout << "Set " << Case << " is immediately decodable" << endl;
			else
				cout << "Set " << Case << " is not immediately decodable" << endl;
			Case++;
			initialize();
		}
		else {
			answer = answer && buildTree(encoding,0,&root);
			memset(encoding,0,sizeof(encoding));
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值