UVa 644 - Immediate Decodability

Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable



Miguel A. Revilla 
2000-01-17
开始没读懂什么意思。。。
百度后知道了就是判断给出的一堆01代码有没有其中一个是另一个前缀的情况
若有,输出immediately decodable, 否则输出not immediately decodable
很简单的一道题啊。。。发现百度上的代码怎么都那么长。。。
代码如下:

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#define MAXN 100
#define INF 0x7FFFFFFF
#define ll long long
using namespace std;
int main(void){
	int T = 0;
	char str[MAXN][20];
	while(scanf("%s", str[0]) != EOF){
		T++;
		int k = 1;
		while(scanf("%s", str[k]) && str[k][0]!='9')
		 ++k;
		int flag = 0;
		for(int i=0; i<k; ++i){
			for(int j=i+1; j<k; ++j){
				int len = min(strlen(str[i]), strlen(str[j]));
				int t;
				for(t=0; t<len; ++t){
					if(str[i][t] != str[j][t])
					 break;
				}
				if(t==len)
				 flag = 1;
			}
		}
		if(flag) cout << "Set " << T << " is not immediately decodable" << endl;
		else cout << "Set " << T << " is immediately decodable" << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值