UVa10305 Ordering Tasks

Problem F

Ordering Tasks

Input: standardinput

Output: standardoutput

Time Limit: 1 second

Memory Limit: 32MB

 

John has n tasks to do.Unfortunately, the tasks are not independent and the execution of one task is onlypossible if other tasks have already been executed.

Input

The input will consist of several instances ofthe problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. nis the number of tasks (numbered from 1to n) and m is the number of direct precedence relations between tasks. Afterthis, there will be m lines with twointegers i and j, representing the fact that task i must be executed before task j.An instance with n = m = 0 willfinish the input.

Output

For each instance,print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3

(The Joint Effort Contest, Problem setter:Rodrigo Malta Schmidt)


这题大意就是有n个任务,以及m个前提,各个前提中需完成前一项后才能进行下一项,用的是拓扑排序,根据各个节点间的关系,利用深搜查找以该节点为前提的所有节点,当查找不到时,将其加入拓扑排列的首部,然后输出,具体可见代码。

#include<iostream>
#include<cstring>
using namespace std;

const int N = 102;
int g[N][N];
int c[N];
int topo[N];
int t;
int n,m;

bool dfs(int u){
	c[u] = -1;
	for (int v = 1; v <= n; v++){
		if (g[u][v]){
			if (c[v] < 0)
				return false;
			else if (!c[v] && !dfs(v))
				return false;
		}
	}
	c[u] = 1;
	topo[t] = u;
	t--;
	return true;
}

int main(){
	int x,y;
	while (cin >> n >> m){
		if (n == 0 && m == 0)
			break;

		memset(g,0,sizeof(g));
		memset(c,0,sizeof(c));

		for (int i = 0; i < m; i++){
			cin >> x >> y;
			g[x][y] = 1;
		}
		t = n - 1;

		for (int u = 1; u <= n; u++){
			if (!c[u]){
				dfs(u);
			}
		}

		for (int i = 0; i < n; i++){
			if (!i)
				cout << topo[i];
			else
				cout << " " << topo[i];
		}
		cout << endl;
	}
	return 0;
}


Guava Ordering是一个用于排序的工具类,它为构建复杂的比较器提供了一种流畅的风格。通过使用Guava Ordering,我们可以根据自定义的规则对集合中的元素进行排序。 在Guava Ordering中,有三种静态方法用于创建Ordering排序器:natural()、usingToString()和from(Comparator)。natural()方法使用自然排序规则生成排序器,即从小到大的顺序。usingToString()方法根据元素的toString()方法返回值进行排序。from(Comparator)方法根据给定的Comparator生成排序器。 创建Ordering排序器后,可以使用它对集合或元素进行操作。常见的方法包括sortedCopy(List)、immutableSortedCopy(Iterable)、min(E, E)和max(E, E)等。sortedCopy(List)方法返回一个已排序的List副本,immutableSortedCopy(Iterable)方法返回一个不可变的已排序集合,min(E, E)方法返回两个元素中较小的那个,max(E, E)方法返回两个元素中较大的那个。 下面是一个示例代码,展示了如何使用Guava Ordering对People类的age属性进行排序: List<People> peopleList = new ArrayList<People>() { { add(new People("A", 33)); add(new People("B", 11)); add(new People("C", 18)); } }; Ordering<People> ordering = Ordering.natural().onResultOf(new Function<People, Comparable>() { @Override public Comparable apply(People people) { return people.getAge(); } }); for (People p : ordering.sortedCopy(peopleList)) { System.out.println(MoreObjects.toStringHelper(p) .add("name", p.getName()) .add("age", p.getAge())); } 这段代码中,我们首先创建了一个包含People对象的List。然后使用Ordering.natural().onResultOf()方法创建了一个排序器,该排序器按照People对象的age属性进行排序。最后,我们通过ordering.sortedCopy()方法将集合按照排序规则进行排序,并打印排序后的结果。 通过使用Guava Ordering,我们可以轻松地实现各种排序需求,并且可以方便地链式调用方法来定制和增强现有的比较器。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值