UVa10305 Ordering Tasks

Problem F

Ordering Tasks

Input: standardinput

Output: standardoutput

Time Limit: 1 second

Memory Limit: 32MB

 

John has n tasks to do.Unfortunately, the tasks are not independent and the execution of one task is onlypossible if other tasks have already been executed.

Input

The input will consist of several instances ofthe problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. nis the number of tasks (numbered from 1to n) and m is the number of direct precedence relations between tasks. Afterthis, there will be m lines with twointegers i and j, representing the fact that task i must be executed before task j.An instance with n = m = 0 willfinish the input.

Output

For each instance,print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3

(The Joint Effort Contest, Problem setter:Rodrigo Malta Schmidt)


这题大意就是有n个任务,以及m个前提,各个前提中需完成前一项后才能进行下一项,用的是拓扑排序,根据各个节点间的关系,利用深搜查找以该节点为前提的所有节点,当查找不到时,将其加入拓扑排列的首部,然后输出,具体可见代码。

#include<iostream>
#include<cstring>
using namespace std;

const int N = 102;
int g[N][N];
int c[N];
int topo[N];
int t;
int n,m;

bool dfs(int u){
	c[u] = -1;
	for (int v = 1; v <= n; v++){
		if (g[u][v]){
			if (c[v] < 0)
				return false;
			else if (!c[v] && !dfs(v))
				return false;
		}
	}
	c[u] = 1;
	topo[t] = u;
	t--;
	return true;
}

int main(){
	int x,y;
	while (cin >> n >> m){
		if (n == 0 && m == 0)
			break;

		memset(g,0,sizeof(g));
		memset(c,0,sizeof(c));

		for (int i = 0; i < m; i++){
			cin >> x >> y;
			g[x][y] = 1;
		}
		t = n - 1;

		for (int u = 1; u <= n; u++){
			if (!c[u]){
				dfs(u);
			}
		}

		for (int i = 0; i < n; i++){
			if (!i)
				cout << topo[i];
			else
				cout << " " << topo[i];
		}
		cout << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值