Ordering Tasks From:UVA, 10305(拓扑排序)



 Ordering Tasks

From:UVA, 10305

Submit

Time Limit: 3000 MS       Special Judge

 

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and mn is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3

题目大意:

用N份工作,M组关系,例如关系A,B表示要先完成B,才能完成A,让你输出一组工作完成的顺序。

解题思路:

  拓扑排序。


代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<string>
using namespace std;

const int maxn=110,maxm=100000;

struct edge{
    int u,v,next;
    edge(int u0=0,int v0=0,int next0=0){u=u0,v=v0,next=next0;}
}e[maxm];

int n,m,inDegree[maxn],head[maxn],cnt;
queue <int> path;

void initial(){
    cnt=0;
    for(int i=0;i<=n;i++){
        inDegree[i]=0;
        head[i]=-1;
    }
}

void adde(int u,int v){
    e[cnt].u=u,e[cnt].v=v,e[cnt].next=head[u],head[u]=cnt++;
}

void input(){
    int a,b;
    for(int i=0;i<m;i++){
        scanf("%d%d",&a,&b);
        adde(a,b);
        inDegree[b]++;
    }
}

void tuopu(){
    queue <int> q;
    for(int i=1;i<=n;i++)if(inDegree[i]==0) q.push(i);
    while(!q.empty()){
        int s=q.front();
        path.push(s);
        q.pop();
        for(int i=head[s];i!=-1;i=e[i].next){
            inDegree[e[i].v]--;
            if(inDegree[e[i].v]==0) q.push(e[i].v);
        }
    }
}

void outResult(){
    while(!path.empty()){
        printf("%d",path.front());
        path.pop();
        if(!path.empty()) printf(" ");
    }
    printf("\n");
}

int main(){
    while(cin>>n>>m&&(n||m)){
        initial();
        input();
        tuopu();
        outResult();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值