UVa10034 Freckles

Problem A: Freckles

In an episode of the Dick Van Dyke show, little Richie connects the freckleson his Dad's back to form a picture of the Liberty Bell. Alas, one of thefreckles turns out to be a scar, so his Ripley's engagement falls through.

Consider Dick's back to be a plane with freckles at various (x,y) locations.Your job is to tell Richie how to connect the dots so as to minimize theamount of ink used. Richie connects the dots by drawing straight linesbetween pairs, possibly lifting the pen between lines.When Richie is done there must bea sequence of connected lines from any freckle to any other freckle.

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The first line contains 0 < n <= 100, the number of freckleson Dick's back. For each freckle, a line follows; each following linecontains two real numbers indicating the (x,y) coordinates of thefreckle.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

Your program prints a single real number to two decimal places: theminimum total length of ink lines that can connect all the freckles.

Sample Input

1

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41


这题大意其实就是求个最小生成树,题目中是给定了许多各点,所以整个会是一个完全图,可以用prim算法。关于prim算法,具体可以见代码。


#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

const int N = 110;
const int INF = 1 << 29;

struct Node {
	double x;
	double y;
}p[N];
int point;
double ans;
double graph[N][N];
double lowcost[N];
double nearvex[N];

void initialize() {
	ans = 0;
	memset(graph,INF,sizeof(graph));
}

void prim(int u) {
	for (int i = 0; i < point; i++)
		lowcost[i] = graph[u][i];
	memset(nearvex,u,sizeof(nearvex));
	nearvex[u] = -1;
	for (int i = 0; i < point; i++) {
		if (i != u) {
			int min = INF;
			int v = 0;
			for (int j = 0; j < point; j++) {
				if (nearvex[j] != -1 && lowcost[j] < min) {
					v = j;
					min = lowcost[j];
				}
			}
			if (v) {
				ans += lowcost[v];
				nearvex[v] = -1;
				for (int j = 0; j < point; j++) {
					if (nearvex[j] != -1 && graph[v][j] < lowcost[j]) {
						lowcost[j] = graph[v][j];
						nearvex[j] = v;
					}
				}
			}
		}
	}
}

int main() {
	int test;
	cin >> test;
	while (test--) {
		initialize();
		cin >> point;
		for (int i = 0; i < point; i++)
			cin >> p[i].x >> p[i].y;
		
		for (int i = 0; i < point; i++) {
			for (int j = 0; j < point; j++) {
				if (i == j)
					continue;
				graph[i][j] = sqrt(pow(p[i].x-p[j].x,2)+pow(p[i].y-p[j].y,2));
			}
		}
		prim(0);
		printf("%.2lf\n",ans);
		if (test)
			cout << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值