UVa10300 Ecological Premium

Problem A

Ecological Premium

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

German farmers are given a premium depending onthe conditions at their farmyard. Imagine the following simplified regulation:you know the size of each farmer's farmyard in square meters and the number ofanimals living at it. We won't make a difference between different animals,although this is far from reality. Moreover you have information about thedegree the farmer uses environment-friendly equipment and practices, expressedin a single integer greater than zero. The amount of money a farmer receivescan be calculated from these parameters as follows. First you need the space asingle animal occupies at an average. This value (in square meters) is thenmultiplied by the parameter that stands for the farmer'senvironment-friendliness, resulting in the premium a farmer is paid per animalhe owns. To compute the final premium of a farmer just multiply this premiumper animal with the number of animals the farmer owns.

Input

Thefirst line of input contains a single positive integer n (<20), the number of test cases. Each test case starts with aline containing a single integer f(0<f<20), the number of farmers in the test case. This line isfollowed by one line per farmer containing three positive integers each: thesize of the farmyard in square meters, the number of animals he owns and theinteger value that expresses the farmer’s environment-friendliness. Input isterminated by end of file. No integer in the input is greater than 100000 or less than 0.

 

Output

Foreach test case output one line containing a single integer that holds thesummed burden for Germany's budget, which will always be a whole number. Do notoutput any blank lines.

 

Sample Input

3
5
1 1 1
2 2 2
3 3 3
2 3 4
8 9 2
3
9 1 8
6 12 1
8 1 1
3
10 30 40
9 8 5
100 1000 70

SampleOutput

38

86

7445


(The Joint Effort Contest, Problem setter: Frank Hutter)

 

这题其实就是要找规律,对于每个样例,将每行输入的第一个和第三个数字相乘并累加即可,无需理会第二个数字。

#include <iostream>
using namespace std;

int main() {
	int Case;
	cin >> Case;
	while (Case--) {
		int Test;
		int s = 0;
		int x;
		int y;
		int z;
		cin >> Test;
		while (Test--) {
			cin >> x >> y >> z;
			s += x * z;
		}
		cout << s << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值