bollyrui的个人学习笔记

专注,执着,坚持,热爱学习

排序:
默认
按更新时间
按访问量

Cloud9 安装laravel5.1

1、首先创建自己的Cloud9的应用workspace,选择php环境 2、删除里面的生成的文件,rm README.md php.ini hello-world.php3、安装composercurl -sS https://getcomposer.org/installer | php4、将...

2015-09-02 13:59:48

阅读数:732

评论数:0

laravel 5.5 测试数据seed

1:先创建users表的seeder;##生成/database/seeds/UsersTableSeeder.phpphp artisan make:seeder UsersTableSeeder2:添加run();生成user表中的10个实例 public function run() ...

2018-05-22 16:35:27

阅读数:147

评论数:0

ubuntu 修改telnet 默认23端口

sudo vi /etc/services   找到telnet =23并修改之sudo /etc/init.d/openbsd-inetd restart

2018-04-02 18:34:36

阅读数:105

评论数:0

Parse error: syntax error, unexpected '?' in /home/ubuntu/workspace/vendor/laravel/framework/src/Ill

Parse error: syntax error, unexpected '?' in /home/ubuntu/workspace/vendor/laravel/framework/src/Illuminate/Foundation/helpers.php on line 233出现这个问题的...

2018-03-28 10:00:49

阅读数:145

评论数:0

安装laravel时的一些坑

缺少应用造成的错误:缺少 zip unzip 包Failed to download laravel/laravel from dist: The zip extension and unzip command are both missing, skipping.The php.ini used...

2018-03-26 10:16:30

阅读数:79

评论数:0

linux 修改mysql默认端口3306

linux 修改mysql默认端口3306cd /etc/mysql/my.cnf修改两处 客户端的port=3306 和mysqld的服务器端口port=3306 [client] port=3306 [mysqld] port=3306 重启mysql服务器即可sudo service ...

2018-03-24 09:36:51

阅读数:302

评论数:0

Ubuntu 修改ssh远程连接端口

[root@localhost /]# vi /etc/ssh/sshd_config Port 22 #修改默认端口 保存并退出 [root@localhost /]#service ssh restart

2018-03-23 11:58:34

阅读数:51

评论数:0

ubuntu 安装mysql

apt-get ​install mysql-server mysql-client 输入mysql密码 cd /etc/mysql vim my.cnf 注释 bind-address = 127.0.0.1 查看端口 netstat -an | gr...

2017-08-31 17:23:42

阅读数:93

评论数:0

laravel 中如何使用自定义函数

在app目录下定义一个hextorgb.php (定义的位置可随意)在composer.json中的autoload的files中添加你定义好的目录 如我这里是添加 app/hextorgb.php "autoload": { "classma...

2017-08-25 14:12:45

阅读数:274

评论数:0

欢迎使用CSDN-markdown编辑器

对于这个问题,还真是搜索了大量的资料,网上就没有个现成的好的文档进行说明一下,该如何弄。没办法自己搞吧。黄天不负有心人,经过一下午的搜索查找,筛选,终于找到一个纯PHP实现的中文切分工具。名称:PHPAnalysis官方网址:http://www.phpbone.com/phpanalysis/但...

2016-12-13 10:29:41

阅读数:142

评论数:0

在 Laravel 中使用 Laravel Searchy 扩展包实现基于数据库的轻量级搜索功能

Laravel Searchy是一个易上手的、 轻量级的、支持MySQL的Laravel搜索扩展包,使用该扩展包可以简单高效的实现基于模型的数据查询搜索功能,该扩展包还可以基于你所启用的搜索引擎实现模糊搜索和其它加权机制。此外,不需要服务器安装任何其它软件即可开始使用该扩展包。安装我们使用Comp...

2016-09-03 17:41:00

阅读数:856

评论数:0

ubuntu 安装redis

获取Redis **1、通过官网http://redis.io/获取稳定版源码包下载地址; 通过下载 源码包; wget http://download.redis.io/releases/redis-3.0.2.tar.gz 解压源码包tar -xvf redis-3.0.2.tar.g...

2016-08-25 18:33:08

阅读数:169

评论数:0

Mysql 报错:ERROR 2003 (HY000): Can't connect to MySQL server on '192.168.xxx.xxx' (111)

首先看下 sudo vi /etc/mysql/my.cnf 配置文件#bind-address = 127.0.0.1 【将其注释】sudo service mysql restart ##将mysql重启,如果还连不上,就禁掉防火墙sudo ufw disable然后mysql再...

2016-08-16 10:03:44

阅读数:439

评论数:0

ubuntu 安装 vsftp

sudo apt-get update sudo apt-get install vsftpd sudo service vsftpd restart 新建”/home/uftp”目录作为用户主目录 sudo mkdir /home/uftp 新建用户uftp并设 ...

2016-08-10 12:43:50

阅读数:303

评论数:0

0% [Connecting to archive.ubuntu.com (2001:67c:1360:8001::21)] [Connecting to s

root@caoruidong:~# apt-get update 0% [Connecting to archive.ubuntu.com (2001:67c:1360:8001::21)] [Connecting to s有时候ubuntu不走ipv6, 解决方案:sudo nano /e...

2016-08-10 11:13:27

阅读数:3243

评论数:0

no app specified on the heroku

No app specified. Run this command from an app folder or specify which app to use with --app <app name>为了解决这个问题,您需要添加一个远程heroku应用程序的Git存储库和告诉he...

2016-07-04 10:20:42

阅读数:737

评论数:0

php 部署到heroku上

1、先注册heroku账号 2、先安装heroku toolbelt 工具 https://toolbelt.heroku.com/debianwget -O- https://toolbelt.heroku.com/install-ubuntu.sh | shheroku login 输...

2016-07-03 15:47:31

阅读数:652

评论数:0

laravel5和execl应用

laravel5和execl应用首先在Laravel项目根目录下使用Composer安装依赖:composer require maatwebsite/excel ~2.0.0同样在 config/app.php 中注册门面到 aliases 数组:'Excel' => Maatwebsit...

2016-06-20 17:42:04

阅读数:434

评论数:0

laravel 实现邮箱event事件发送

触发时间监听 所在目录 app\Providers\EventServiceProvider.php 设置监听对象userRegistered,分配事件行为发送邮件 sendRegisterEmail App\Events\UserRegistered protected $listen...

2016-06-15 17:38:20

阅读数:1236

评论数:0

Forms & HTML Laravel5

composer.json “require”: { “laravelcollective/html”: “5.2.*” } 然后更新 composer update config/app.php providers ‘providers’ =>...

2016-06-01 11:26:54

阅读数:215

评论数:0

提示
确定要删除当前文章?
取消 删除
关闭
关闭