Improving the GPA(hdu4968)dfs

Improving the GPA

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 206 Accepted Submission(s): 168


Problem Description
Xueba: Using the 4-Point Scale, my GPA is 4.0.

In fact, the AVERAGE SCORE of Xueba is calculated by the following formula:
AVERAGE SCORE = ∑(Wi * SCOREi) / ∑(Wi) 1<=i<=N

where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.

To simplify the problem, we assume that the credit of each course is 1. In this way, the AVERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.

In SYSU, the university usually uses the AVERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There are 2 ways of transforming each score to 4-Point Scale. Here is one of them.


The student’s average GPA in the 4-Point Scale is calculated as follows:
GPA = ∑(GPAi) / N

So given one student’s AVERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale.
 

 

Input
The input begins with a line containing an integer T (1 < T < 500), which denotes the number of test cases. The next T lines each contain two integers AVGSCORE, N (60 <= AVGSCORE <= 100, 1 <= N <= 10).
 

 

Output
For each test case, you should display the minimum and maximum value of the GPA in the 4-Point Scale in one line, accurate up to 4 decimal places. There is a space between two values.
 

 

Sample Input
4
75 1
75 2
75 3
75 10
 

 

Sample Output
3.0000 3.0000
2.7500 3.0000
2.6667 3.1667
2.4000 3.2000
Hint
In the third case, there are many possible ways to calculate the minimum value of the GPA in the 4-Point Scale.
For example,
Scores 78 74 73 GPA = (3.0 + 2.5 + 2.5) / 3 = 2.6667
Scores 79 78 68 GPA = (3.0 + 3.0 + 2.0) / 3 = 2.6667
Scores 84 74 67 GPA = (3.5 + 2.5 + 2.0) / 3 = 2.6667
Scores 100 64 61 GPA = (4.0 + 2.0 + 2.0) / 3 = 2.6667
 
 
题意:前面的都是废话,重要的是GPA = ∑(GPAi) / N,看懂这个和那张表就可以了,
   说白了,就是让你求平均绩点;
思路:最小的绩点就让成绩尽量往前靠,反之,最大的绩点就是让成绩尽量往后靠,这里指的是区间段;
 
 
ps:http://acm.hdu.edu.cn/showproblem.php?pid=4968
 
#include<stdio.h>
#include<string.h>
int l[5]= {60,70,75,80,85};
int r[5]= {69,74,79,84,100};
double gpa[5]= {2.0,2.5,3.0,3.5,4.0};

int avg,N,sum,P,Q;
double maxgpa,mingpa;
bool flag;

void dfs1(int t1,int t2,int a,int b,double c)
{
    if(flag) return ;
    if(t2==0&&a<=sum&&b>=sum)
    {
        mingpa=c;
        flag=true;
        return ;
    }
    if(t1>4||t2==0) return ;
    for(int i=t2; i>=0; i--)
    {
        dfs1(t1+1,t2-i,a+l[t1]*i,b+r[t1]*i,c+gpa[t1]*i);
    }
}
void dfs2(int t1,int t2,int a,int b,double c)
{
    if(flag) return ;
    if(t2==0&&a<=sum&&b>=sum)
    {
        maxgpa=c;
        flag=true;
        return ;
    }
    if(t1<0||t2==0) return ;
    for(int i=t2; i>=0; i--)
    {
        dfs2(t1-1,t2-i,a+l[t1]*i,b+r[t1]*i,c+gpa[t1]*i);
    }
}

int main()
{
    int T,i,j,k,l;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&avg,&N);
        sum=avg*N;
        maxgpa=mingpa=0;

        flag=false;
        dfs1(0,N,0,0,0);
        flag=false;
        dfs2(4,N,0,0,0);
        printf("%.4lf %.4lf\n",mingpa/N,maxgpa/N);
    }
    return 0;
}

dfs自己还用的不是很好,比赛的时候等我写完,我们队的其他人已经过了。。。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值