Modular Inverse(zoj3609+欧几里德)

ZOJ Problem Set - 3609
Modular Inverse

Time Limit: 2 Seconds        Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist
8
References

Author:   WU, Zejun
Contest:   The 9th Zhejiang Provincial Collegiate Programming Contest

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

首先我来回顾下欧几里德的几个定理,有助于理解这道题;

   定理一:如果d = gcd(a, b),则必能找到正的或负的整数k和l,使 d = a*x+ b*y。

   定理二:若gcd(a, b) = 1,则方程ax ≡ c (mod b)在[0, b-1]上有唯一解。

   定理三:若gcd(a, b) = d,则方程ax ≡ c (mod b)在[0, b/d - 1]上有唯一解。


转载请注明出处:寻找&星空の孩子

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4712

对于ax+by=1;  即ax=1(mod b)      当且仅当gcd(a,b)!=1 的时候,无解!

 

 

#include<stdio.h>

void exgcd(int a,int b,int &d,int &x,int &y)
{
    if(!b){d=a;x=1;y=0;}
    else
    {
        exgcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}
int main()
{
    int T,a,m;
    scanf("%d",&T);
    while(T--)
    {
        int d,x,y;
        scanf("%d%d",&a,&m);
        exgcd(a,m,d,x,y);
        if(d==1)
        {
            while(x<=0)
            {
                x+=m/d;
            }
            printf("%d\n",x);
        }
        else
            printf("Not Exist\n");
    }
    return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值