2468. Counting Letters

两次过,题目要求求出输入字符串中出现频率最高的字符并将其按字母顺序打印出来。

我学到的知识:1. 先将字符串按字母顺序排列,用sort排列;

                            2. 用一个数组记录每个字母出现的频率,因为排序后可相同的字母相邻,故简单了许多。

As a talented student, your boss gave you a task. Given a text string, you should find out which letters appear most frequently.

Really simple, isn't it?

Input

The first line of the input is the number of test cases. Then some test cases followed.

Each test case contains only one line, indicating the string mentioned above.

You can assume there is only lower case letters in the string. The length of the string is more than 0 and no more than 100.

Output

You should output one line for each test case, indicating the most frequent letters. Please note there may be more than one such letter, so you should output all of them, and these letters should be in the same order as the alphabet, that is, 'a', 'b', 'c', 'd' ... 'z'.

Sample Input

2
abcda
tjucstju

Sample Output

a
jtu
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main(){
	int n,l,j,sum,count[100];
	char a[101],b[101],c;
	cin>>n;
	while(n--){
		memset(count,0,sizeof(count));
		cin>>a;
		l=strlen(a);
		sort(a,a+l);
		//for(int i=0;i<l;i++)
		//	cout<<a[i]<<" ";
		//cout<<endl;
		for(int i=0;i<l;i++){
			sum=a[i]-'a';
			count[sum]++;
		}
		
			
		int max=0;
		for(int i=0;i<=26;i++){
			if(max<count[i])
				max=count[i];
		}
		//cout<<1+'0'<<endl;
		for(int i=0;i<=26;i++){
			if(count[i]==max){
				c=i+'a';
				cout<<c;
			}
		}
		cout<<endl;
	

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值