TOJ 1594. Definite Values

A common error in programming is to use variables that have not been initialized before. For example, in C and C++, all variables have an indefinite value after declaration - their value can be anything. Thus, the following program

main()
{
  int x;
  printf("%d\n",x);
}

could print any number. But even in languages such as Pascal, where all values are initialized to zero, it is useful to give variables definite values before using them, the avoid side effects when your code portion is placed into a different context.

Generally, the problem of deciding for a given program whether all variables have been assigned values before they are read out, is undecidable. But if you, as in this problem, consider only a sequence of assignments, the problem becomes solvable.


Input

The input contains several program parts. Each part starts with a number n on a line by itself, the number of lines in the program part. The following n lines contain each an assignment of the form "variable1 = variable2", where the variablei's are lower-case letters.

The input is terminated by a test case starting with n = 0.


Output

Assume that before the execution of the given program part, variable a has some definite value, while all other variables are undefined. You have to print the names of the varaibles which have a definite value after the execution of the program part. More specifically, format your output as follows.

For each program part in the input, first print the number of the program, as shown in the sample output. Then print a line containing the names of the variables which have a definite value after the execution of the given program part. Print them in alphabetically sorted order, and leave one blank after each variable name. If none of the variables has a definite value after the execution of the program part, print the word "none".

Print a blank line after each test case.


Sample Input

4
b = a
c = d
d = b
e = f
1
a = b
0


Sample Output

Program #1
a b d

Program #2
none
#include<iostream>
#include<cstring>
using namespace std;
int main(){
	int n,d[30],k=1,r;
	char a,b,c,m;
	while(cin>>n&&n){
		memset(d,0,sizeof(d));
		d[0]=1;
		r=0;
		for(int i=0;i<n;i++){
			cin>>a>>b>>c;
			//cout<<a<<b<<c<<endl;
			d[a-'a']=d[c-'a'];
		}
		cout<<"Program #"<<k<<endl;
		for(int i=0;i<=26;i++){
			if(d[i]){
				r=1;
				m=i+'a';
				cout<<m<<" ";
			}
		}
		if(!r)
			cout<<"none";
		cout<<endl<<endl;
		k++;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值