互质数的不超时算法

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6

4

所谓两个数互质,指的是其最大公约数为1,如果用最大公约数的方法计算,则一定会超时,因为题目给的整数太大,每计算一个数就要从1开始算,时间复杂度高。

以下为不超时算法,很经典,希望以后还可以用到:

先判断n是否能够被2整除,如果能够,则去掉从1~n包括n的所有偶数,所以总数除以2,这里算作是剪枝。

剩下的不好表示,多看几遍代码就可以理解

#include<iostream>
using namespace std;
int main(){
	int n,x,c;
	while(cin>>n&&n){
		c=n;
		if(n%2==0)
			c=c/2;
		while(n%2==0)
			n=n/2;
		for(int i=3;n>1;i=i+2){
			if(n%i==0){
				c=c-c/i;
				while(n%i==0)
					n=n/i;
			}
		}
		cout<<c<<endl;
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值