BFS 2470. Robot in Maze

There is a robot trapped in the maze. Now you have to send out some instructions, telling it how to reach its destination.

The maze is an M * N grid. Some of the cells are empty, while others are occupied by the wall. Of course the robot can't move into the wall, and the robot can't move outside the grid too. The robot can only accept three commands: TURN LEFT, TURN RIGHT and GO. The robot may face to North, South, East or West during the movement. When it receive a TURN LEFT command, it will rotate 90 degree to the left. That is, if it faces to east before the command, it will face to north after the TURN LEFT command. The TURN RIGHT command is almost the same, except that the direction is opposite. When receive the GO command, the robot will move 1 unit towards its orientation, unless there is a nonempty cell in front of it.

Please note the robot is always face to north at the beginning, i.e., face to the upper border in the maze map. (The maze map will be described below.)

You want to use minimum number of instructions, so you should write a program for help.

Input

The first line of the input is the number of test cases.

The first line of each test case contains two integers M and N, indicating the size of the maze. There are M lines followed, each line contains exactly N characters, describing an M * N maze. The '#' indicating the wall, the '.' indicating the empty cell, the 'S' and 'T' indicating the start point and the destination of the robot respectively. There are no other characters in the maze map.

The orientation of the maze map is just the same as the common sense. That is, the upper-left corner of the maze map indicating the north-west direction, and the lower-right corner indicating the south-east.

You can assume 1 ≤ M ≤ 100 and 1 ≤ N ≤ 100. There is only one 'S' and one 'T' in the maze.

Output

Output one line for each test case, indicating the minimum number of instructions needed. Or output -1 if it's impossible to reach the robot's destination.

Sample Input

2
5 5
#####
#...#
#.#.#
#S#T#
#####
4 5
#.#.#
#.#.#
#S#T#
#####

Sample Output

8

-1

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
const int num=101;
int T,M,N,x,y;
char map[num][num];
int visit[num][num][4];
struct{
	int x,y,step,dire;
}q[40001];
struct{
	int x,y;
}ext[4]={{-1,0},{0,1},{1,0},{0,-1}};//上下左右四个方向

int bfs(){
	memset(visit,0,sizeof(visit));
	int top=0,xt,yt,rt;
	q[top].x=x;
	q[top].y=y;
	q[top].dire=0;
	q[top].step=0;
	visit[x][y][q[top].dire]=1;
	top++;
	for(int i=0;i<top;i++){
		//向前进
		rt=q[i].dire;
		xt=q[i].x+ext[rt].x;
		yt=q[i].y+ext[rt].y;
		if(xt>=0&&xt<M&&yt>=0&&yt<N&&map[xt][yt]!='#'&&!visit[xt][yt][rt]){
			q[top].x=xt;
			q[top].y=yt;
			q[top].dire=rt;
			q[top].step=q[i].step+1;
			top++;
			visit[xt][yt][rt]=1;
			if(map[xt][yt]=='T')
				return q[top-1].step;
		}
		//left
		rt=(q[i].dire+1)%4;
		xt=q[i].x;
		yt=q[i].y;
		if(xt>=0&&xt<M&&yt>=0&&yt<N&&map[xt][yt]!='#'&&!visit[xt][yt][rt]){
			q[top].x=xt;
			q[top].y=yt;
			q[top].dire=rt;
			q[top].step=q[i].step+1;
			top++;
			visit[xt][yt][rt]=1;
			if(map[xt][yt]=='T')
				return q[top-1].step;
		}
		//right
		rt=(q[i].dire+3)%4;
		xt=q[i].x;
		yt=q[i].y;
		if(xt>=0&&xt<M&&yt>=0&&yt<N&&map[xt][yt]!='#'&&!visit[xt][yt][rt]){
			q[top].x=xt;
			q[top].y=yt;
			q[top].dire=rt;
			q[top].step=q[i].step+1;
			top++;
			visit[xt][yt][rt]=1;
			if(map[xt][yt]=='T')
				return q[top-1].step;
		}
	}
	return -1;
}
int main(){
	//int x,y;
	//char c;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&M,&N);
		for(int i=0;i<M;i++){
			scanf("%s",map[i]);
			for(int j=0;j<N;j++){
				
			
				if(map[i][j]=='S'){
					x=i;
					y=j;
				}
			}
		}
		printf("%d\n",bfs());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值