hdu 5014 Number Sequence(意淫题)

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 545    Accepted Submission(s): 258
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4
 

Source
 


题解及题解:


       瞎搞就搞出来了,最后的结果是n*(n+1),手算一下前5个就能看出来。剩下的输出从大开始向下遍历,输出2^(len)-1-i就可以了,边计算边标记(len为当前数的2进制表示形式的位数)。


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int len(int n)
{
    int ans=0;
    while(n)
    {
        n>>=1;
        ans++;
    }
    return ans;
}

int s[100010];
int t[100010];
int main()
{
    int n,le,v;
    __int64 d;
    while(scanf("%d",&n)!=EOF)
    {
        memset(s,-1,sizeof(s[0])*(n+5));
        for(int i=0;i<=n;i++)
        {
            scanf("%d",&t[i]);
        }

        for(int i=n;i>=0;i--)
        if(s[i]<0)
        {
            le=len(i);
            v=1<<le;
            v--;
            s[i]=v-i;
            s[v-i]=i;
        }
        __int64 m=(__int64)n;
        d=m*(m+1);
        printf("%I64d\n",d);
        for(int i=0;i<n;i++)
        {
            printf("%d ",s[t[i]]);
        }
        printf("%d\n",s[t[n]]);
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值