hdu5014 Number Sequence(异或运算)

题目链接:

huangjing

题意:
这个题目的意思是给出0~n的排列,然后找出与这个序列的配对使(a0 ⊕ b0) + (a1 ⊕ b1) +·+ (an ⊕ bn)最大。。
思路:
从大到小遍历每个数,然后找到与这个数二进制位数互补的数,那么他们的抑或值必定是pow(2,n)-1,,肯定是最大的。。。。

题目:

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 713    Accepted Submission(s): 337
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
   
   
4 2 0 1 4 3
 

Sample Output
   
   
20 1 0 2 3 4
 

Source
 
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<vector>
#include<cmath>
#include<string>
#include<queue>
#define eps 1e-9
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;

const int maxn=100000+10;
int a[maxn],n,ans[maxn];
bool vis[maxn];

int gao(int k)
{
    int cnt=0;
    while(k)
    {
        k>>=1;
        cnt++;
    }
    return cnt;
}

int main()
{
    while(~scanf("%d",&n))
    {
        memset(vis,false,sizeof(vis));
        for(int i=0;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=n;i>=0;i--)
        {
            if(vis[i])  continue;
            int move=gao(i);
            int temp=(((1<<move)-1)^i);//找到和i二进制表示互补的数
            ans[temp]=i;
            ans[i]=temp;
            vis[i]=vis[temp]=true;
        }
        ll  sum=0;
        for(int i=0;i<=n;i++)
            sum+=i^ans[i];
        printf("%I64d\n",sum);
        for(int i=0;i<=n;i++)
        {
            if(i==n)
                printf("%d\n",ans[a[i]]);
            else
                printf("%d ",ans[a[i]]);
        }
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值