dijkstra--poj1797

Language:
Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 17946 Accepted: 4733

Description

Background  
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.  
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.  

Problem  
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4
Dijkstra算法所处理的最短路径问题,本质上是使用了,距离标号法,每次选出一条距离最短的路径,不断扩充集合。这道题要求的是从1到n的最大载重,所以扩充时,每次找到载重最大的路径,然后更新,改变剩余边的标号,学习算法一定要体会思想啊。


#include<iostream>
#include<cstring>
using namespace std;
int street[1010][1010];
int dis[1010];
int n,m;
void dijkstra()
{
    bool vis[1010];
    for(int i=1; i<=n; i++)
    {
        dis[i]=street[1][i];
        vis[i]=0;
    }
    dis[1]=0;
    vis[1]=1;
    int w;
    for(int i=2; i<=n; i++)
    {
        int min1=0;
        for(int j=2; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>min1)
            {
                min1=dis[j];
                w=j;
            }
        }
        vis[w]=1;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<min(dis[w],street[w][j]))
            {
                dis[j]=min(dis[w],street[w][j]);
            }
        }
    }
    cout<<dis[n]<<endl<<endl;
}
int main()
{
    int t;
    int u,v,w;
    cin>>t;
    for(int k=1; k<=t; k++)
    {
        cin>>n>>m;
        memset(street,0,sizeof(street));
        for(int i=1; i<=m; i++)
        {
            cin>>u>>v>>w;
            street[u][v]=street[v][u]=w;
        }
        cout<<"Scenario #"<<k<<":"<<endl;
        dijkstra();
    }
    return 0;
}











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值