01分数规划+二分搜索

Language:
Dropping tests
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5119 Accepted: 1770

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

题意:给你n个数,让你删去k个问得到的最大的比值
思路:sum(a[i])/sum(b[i])=y,y*sum(b[i])-sum(a[i])>0
下面是代码:
#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const double eps=10e-6;
double a[1010],b[1010];
double suma,sumb;
int n,k;

int main()
{
    //freopen("in.txt","r",stdin);
    while(cin>>n>>k,n||k)
    {
        for(int i=1; i<=n; i++)
           cin>>a[i];
        for(int i=1; i<=n; i++)
           cin>>b[i];
        double t[1000];
        double l=0.0,r=1.0,mid;
        while(r-l>eps)
        {
            mid=(l+r)/2;
            for(int i=1;i<=n;i++)
                t[i]=mid*b[i]-a[i];
            sort(t+1,t+n+1);
            double tmp=0;
            for(int i=1;i<=n-k;i++)
                tmp+=t[i];
            if(tmp>0)
                r=mid;
            else
                l=mid;
        }
        printf("%.0f\n",l*100);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值