字符串hash+hdu4821(2013长春现场赛)

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests
Author ID 
Password 
  Register new ID
BestCoder官方群:385386683 欢迎加入~
寻人启事:2014级新生看过来!

String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 792    Accepted Submission(s): 224


Problem Description
Given a string S and two integers L and M, we consider a substring of S as “recoverable” if and only if
  (i) It is of length M*L;
  (ii) It can be constructed by concatenating M “diversified” substrings of S, where each of these substrings has length L; two strings are considered as “diversified” if they don’t have the same character for every position.

Two substrings of S are considered as “different” if they are cut from different part of S. For example, string "aa" has 3 different substrings "aa", "a" and "a".

Your task is to calculate the number of different “recoverable” substrings of S.
 

Input
The input contains multiple test cases, proceeding to the End of File.

The first line of each test case has two space-separated integers M and L.

The second ine of each test case has a string S, which consists of only lowercase letters.

The length of S is not larger than 10^5, and 1 ≤ M * L ≤ the length of S.
 

Output
For each test case, output the answer in a single line.
 

Sample Input
      
      
3 3 abcabcbcaabc
 

Sample Output
      
      
2


当年就是菜鸟,什么都不会

就是简单的hash

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=100010;
const int B=123;
typedef unsigned long long LL;
LL H[maxn],xp[maxn],hash[maxn];
int M,L,n;
map<LL,int> m;
char s[maxn];

void gethash()
{
    H[n]=0;
    for(int i=n-1;i>=0;i--)
        H[i]=H[i+1]*B+(s[i]-'a');

}
int main()
{
    xp[0]=1;
    for(int i=1;i<maxn;i++)xp[i]=xp[i-1]*B;
    while(scanf("%d%d",&M,&L)!=EOF)
    {
        scanf("%s",s);
        n=strlen(s);
        gethash();
        int ans=0;
        for(int i=0;i<L;i++)
        {
            int cnt=0;
            for(int j=i;j+L<=n;j+=L)
                hash[++cnt]=H[j]-H[j+L]*xp[L];
            m.clear();
            for(int j=1;j<=cnt;j++)
            {
                if(j-M>=1)
                {
                    if(m[hash[j-M]]>1)m[hash[j-M]]--;
                    else m.erase(hash[j-M]);
                }
                m[hash[j]]++;
                if(m.size()==M&&j-M>=0)ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值