Prime Ring Problem

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 7
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2



#include <iostream>
#include <math.h>
using namespace std;
int n,depth=0,a,b;//depth记录当前递归的层数
int visit[25] //记录元素是否用过
int solution[25];//解数组
bool fun(int num)
{
    for(int i=2 ; i<=sqrt(num) ; ++i)
    {
        if(num % i == 0)
        {
            return false;
        }
    }
    return true;
}
void dfs(int x)
{
     if(depth == n-1 && fun(x+1)) //终止条件,若已经填入了n-1个数字(1认为已经填入了) 且最后一个与1相加素数
    {
        cout << "1";  //从1开始,1第一个输出
        for(int i=0 ; i<n-1 ; ++i)  //输出结果
        {
            cout << " " << solution[i];
        }
        cout << endl;
        return ;
    }


        for(int i=2;i<=n;++i)
        {
            if(visit[i]==0&&fun(x+i))//若i没被使用,且和为素数
            {
                solution[depth]=i;
                depth++;//深度增加1
                visit[i]=1; //使用状态置1  

          dfs(i);//递归调用
                visit[i]=0;使用状态置0
                depth--;回溯 深度减一
            }
        }
    return ;
}
int main ()
{ int id=0;
  while(cin>>n)
  {
      for(int i=0;i<=n;++i)
        visit[i]=0;
      visit[1]=1;
      cout<<"Case "<<++id<<":"<<endl;
      dfs(1);
      cout<<endl;
  }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值