HDU:Prime Ring Problem

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 35   Accepted Submission(s) : 23
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. You are to write a program that completes above process. Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

翻译:

有一个整数n,把从1到n的数字无重复的排列成环,且使每相邻两个数(包括首尾)的和都为素数,称为素数环。

为了简便起见,我们规定每个素数环都从1开始。


直接dfs就出来了。


源代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int t,c[22];
bool lu[22];//标记已用过的数
bool su(int n)//判断素数
{
    for(int i=2;i<n;i++)
        if(n%i==0)return false;
    return true;
}
void DFS(int n)
{
    if(t==n)
    {
        if(su(c[t-1]+1))
        {
            printf("%d",c[0]);
            for(int i=1;i<t;i++)
            {
                printf(" %d",c[i]);
            }
            printf("\n");
        }
    }
    for(int i=2;i<=t;i++)
    {
        if(lu[i]) continue;
        if(su(i+c[n-1]))
        {
            lu[i]=1;
            c[n]=i;
            DFS(n+1);
            lu[i]=0;
        }
    }

}
int main()
{
    int f=1;
    while(cin>>t)
    {
        printf("Case %d:\n",f++);
        memset(lu,0,sizeof(lu));
        c[0]=1;
        DFS(1);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值