Farey Sequence
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 11067 | Accepted: 4267 |
Description
The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10
6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input
2 3 4 5 0
Sample Output
1 3 5 9
Source
POJ Contest,Author:Mathematica@ZSU
题型:数论
题意:求n以内所有互质的数的对数
分析:
先预处理出10^7以内的所有的欧拉函数值φ( i ),然后累加从2到n的phi即可。(题目中将讲n<10^6,开了123456返了个RE,改成1234567就AC了,无解。。。)
代码:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#define LL long long
using namespace std;
const int maxn=1234567;
int phi[maxn];
void getphi(){
memset(phi,0,sizeof(phi));
phi[1]=1;
for(int i=2;i<maxn;i++){
if(!phi[i]){
for(int j=i;j<maxn;j+=i){
if(!phi[j])
phi[j]=j;
phi[j]=phi[j]/i*(i-1);
}
}
}
}
int main(){
getphi();
int n;
while(scanf("%d",&n)&&n){
LL sum=0;
for(int i=2;i<=n;i++){
sum+=(LL)phi[i];
}
printf("%I64d\n",sum);
}
return 0;
}