X - Farey Sequence POJ - 2478

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

题解:这一题就是欧拉函数的模拟题,做题的时候,没有考虑数值的大小,就做错了。

#include<stdio.h>
#include<string.h>
__int64 e[1000005],ans[1000005];
void fun()  
{
    int i,j;
    for(i=2; i<1000005; i++)
        if(!e[i])
            for(j=i; j<1000005; j+=i)
            {
                if(!e[j])
                    e[j]=j;
                e[j]=e[j]-e[j]/i;
            }
    for(i=1; i<1000005; i++)
        ans[i]=ans[i-1]+e[i];
}
int main()
{
    int n;
    fun();
    while(~scanf("%d",&n)&&n)
        printf("%I64d\n",ans[n]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值