poj_1102_LC-Display(数段码模拟)

LC-Display
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14450 Accepted: 5768

Description

A friend of you has just bought a new computer. Until now, the most powerful computer he ever used has been a pocket calculator. Now, looking at his new computer, he is a bit disappointed, because he liked the LC-display of his calculator so much. So you decide to write a program that displays numbers in an LC-display-like style on his computer.

Input

The input contains several lines, one for each number to be displayed. Each line contains two integers s, n (1 <= s <= 10, 0 <= n <= 99 999 999), where n is the number to be displayed and s is the size in which it shall be displayed. 

The input file will be terminated by a line containing two zeros. This line should not be processed.

Output

Output the numbers given in the input file in an LC-display-style using s "-" signs for the horizontal segments and s "|" signs for the vertical ones. Each digit occupies exactly s+2 columns and 2s+3 rows. (Be sure to fill all the white space occupied by the digits with blanks, also for the last digit.) There has to be exactly one column of blanks between two digits. 

Output a blank line after each number. (You will find a sample of each digit in the sample output.)

Sample Input

2 12345
3 67890
0 0

Sample Output

      --   --        -- 
   |    |    | |  | | 
   |    |    | |  | | 
      --   --   --   -- 
   | |       |    |    |
   | |       |    |    |
      --   --        -- 

 ---   ---   ---   ---   --- 
|         | |   | |   | |   |
|         | |   | |   | |   |
|         | |   | |   | |   |
 ---         ---   --- 
|   |     | |   |     | |   |
|   |     | |   |     | |   |
|   |     | |   |     | |   |
 ---         ---   ---   ---

Source


题型:模拟


题意:按要求的大小输出LCD数字串


分析:一开始想一个一个的打出来,但是发现是数字串要一起打出来,于是将1Size的给存起来,执行的时候中间的笔画打印n遍就可以了。(一不小心不3中间的线打成下划线了,WA出翔了。。)


注意点

1、第一个数字之前与最后一个数字之后木有空格。

2、每个样例之间输出一个空行

3、只要判断size=0就跳出就行,不需要判断字符串是否为0


代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
char n1[]={" -     -  -     -  -  -  -  - "};
char n2[]={"| |  |  |  || ||  |    || || |"};
char n3[]={"       -  -  -  -  -     -  - "};
char n4[]={"| |  ||    |  |  || |  || |  |"};
char n5[]={" -     -  -     -  -     -  - "};
int main(){
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    char s[1000];
    while(1){
        scanf("%d%s",&n,s);
        if(n==0) break;
        int len=strlen(s);
        for(int i=0;i<len;i++){//First Line
            for(int j=(s[i]-'0')*3;j<(s[i]-'0')*3+3;j++){
                if(j==(s[i]-'0')*3+1){
                    for(int k=0;k<n;k++){
                        printf("%c",n1[j]);
                    }
                }
                else{
                    printf("%c",n1[j]);
                }
            }
            if(i!=len-1)
                printf(" ");
        }
        printf("\n");

        for(int k=0;k<n;k++){//上半部分打印n遍
            for(int i=0;i<len;i++){
                for(int j=(s[i]-'0')*3;j<(s[i]-'0')*3+3;j++){
                    if(j==(s[i]-'0')*3+1){
                        for(int k=0;k<n;k++){
                            printf("%c",n2[j]);
                        }
                    }
                    else{
                        printf("%c",n2[j]);
                    }
                }
                if(i!=len-1)
                    printf(" ");
            }
            printf("\n");
        }
        //Mid Line
        for(int i=0;i<len;i++){
            for(int j=(s[i]-'0')*3;j<(s[i]-'0')*3+3;j++){
                if(j==(s[i]-'0')*3+1){
                    for(int k=0;k<n;k++){
                        printf("%c",n3[j]);
                    }
                }
                else{
                    printf("%c",n3[j]);
                }
            }
            if(i!=len-1)
                printf(" ");
        }
        printf("\n");
        //打印后半部分
        for(int k=0;k<n;k++){
            for(int i=0;i<len;i++){
                for(int j=(s[i]-'0')*3;j<(s[i]-'0')*3+3;j++){
                    if(j==(s[i]-'0')*3+1){
                        for(int k=0;k<n;k++){
                            printf("%c",n4[j]);
                        }
                    }
                    else{
                        printf("%c",n4[j]);
                    }
                }
                if(i!=len-1)
                    printf(" ");
            }
            printf("\n");
        }
        //Last Line
        for(int i=0;i<len;i++){
            for(int j=(s[i]-'0')*3;j<(s[i]-'0')*3+3;j++){
                if(j==(s[i]-'0')*3+1){
                    for(int k=0;k<n;k++){
                        printf("%c",n5[j]);
                    }
                }
                else{
                    printf("%c",n5[j]);
                }
            }
            if(i!=len-1)
                printf(" ");
        }
        printf("\n");
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值