poj1102 LC-Display

LC-Display
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13320 Accepted: 5247

Description

A friend of you has just bought a new computer. Until now, the most powerful computer he ever used has been a pocket calculator. Now, looking at his new computer, he is a bit disappointed, because he liked the LC-display of his calculator so much. So you decide to write a program that displays numbers in an LC-display-like style on his computer.

Input

The input contains several lines, one for each number to be displayed. Each line contains two integers s, n (1 <= s <= 10, 0 <= n <= 99 999 999), where n is the number to be displayed and s is the size in which it shall be displayed.

The input file will be terminated by a line containing two zeros. This line should not be processed.

Output

Output the numbers given in the input file in an LC-display-style using s "-" signs for the horizontal segments and s "|" signs for the vertical ones. Each digit occupies exactly s+2 columns and 2s+3 rows. (Be sure to fill all the white space occupied by the digits with blanks, also for the last digit.) There has to be exactly one column of blanks between two digits.

Output a blank line after each number. (You will find a sample of each digit in the sample output.)

Sample Input

2 12345
3 67890
0 0

Sample Output

      --   --        -- 
   |    |    | |  | | 
   |    |    | |  | | 
      --   --   --   -- 
   | |       |    |    |
   | |       |    |    |
      --   --        -- 

 ---   ---   ---   ---   --- 
|         | |   | |   | |   |
|         | |   | |   | |   |
|         | |   | |   | |   |
 ---         ---   --- 
|   |     | |   |     | |   |
|   |     | |   |     | |   |
|   |     | |   |     | |   |
 ---         ---   ---   ---

Source

Mid-Central European Regional Contest 1999


话说很简单,就是打印大小为n的数字,但是各种PE卡的蛋疼
首先末尾要多个空格,但是他只说两个数字之间要有个空格啊。。。。
然后每行的数字后面空格要填完
最后每个测试数据之后有个空行。。。。
代码
#include <stdio.h>
#include <string.h>

char zm[10][10][10]=
{
    {
       " - ",
       "| |",
       "   ",
       "| |",
       " - "
    },
    {
       "   ",
       "  |",
       "   ",
       "  |",
       "   "
    },
    {
       " - ",
       "  |",
       " - ",
       "|  ",
       " - "
    },
    {
       " - ",
       "  |",
       " - ",
       "  |",
       " - "
    },
    {
       "   ",
       "| |",
       " - ",
       "  |",
       "   "
    },
    {
       " - ",
       "|  ",
       " - ",
       "  |",
       " - "
    },
    {
       " - ",
       "|  ",
       " - ",
       "| |",
       " - "
    },
    {
       " - ",
       "  |",
       "   ",
       "  |",
       "   "
    },
    {
       " - ",
       "| |",
       " - ",
       "| |",
       " - "
    },
    {
       " - ",
       "| |",
       " - ",
       "  |",
       " - "
    }
};

char str[100];

void Expend(char *s,int re)
{
    int i;
    printf("%c",s[0]);
    for (i=0;i<re;i++)
    {
        printf("%c",s[1]);
    }
    printf("%c",s[2]);
}

int main()
{
    int i,j,n;
    while(1)
    {
        scanf("%d",&n);
        scanf("%s",str);
        if (n==0) break;
        for (i=0;i<2*n+3;i++)
        {
            for (j=0;j<strlen(str);j++)
            {
                if (i==0)
                {
                    Expend(zm[str[j]-'0'][0],n);
                }
                else if (i==n+1)
                {
                    Expend(zm[str[j]-'0'][2],n);
                }
                else if (i==2*n+2)
                {
                    Expend(zm[str[j]-'0'][4],n);
                }
                else if (i<n+1)
                {
                    Expend(zm[str[j]-'0'][1],n);
                }
                else
                {
                    Expend(zm[str[j]-'0'][3],n);
                }
                printf(" ");
            }
            printf("\n");
        }
        printf("\n");
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值