poj_1129_Channel Allocation(四色定理)

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11004 Accepted: 5652

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

Source


题型:图论(暴力DFS)


题意:有n个中继站用来接收和发送频道,相邻的中继站之间不能接收和发送相同的频道,input中给出每一个中继站的相邻中继站。由于无线电频道是一有限的,一个给定的网络所需的中继频道数目应减至最低。问最低需要几个频道。


分析:很容易想到四色定理,但是不能单纯的就用贪心来做,顺序搜索的方法有误。采用DFS暴搜,根据四色定理,频道数最多不会超过4。


代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
char a[50];
int path[50][50],vis[50],n,ans;

int fun(int d,int color){
    for(int i=0;i<n;i++){
        if(i!=d&&path[i][d]==1&&vis[i]==color)
            return 0;
    }
    return 1;
}

void dfs(int x){
    int i,j,maxn=-1;
    if(x==n){
        for(int i=0;i<n;i++){
            maxn=max(maxn,vis[i]);
        }
        ans=min(ans,maxn);
        return;
    }
    for(i=x;i<n;i++){
        for(j=1;j<5;j++){
            if(fun(i,j)==1){
                vis[i]=j;
                dfs(i+1);
            }
        }
    }
}


int main(){
    while(scanf("%d",&n)&&n){
        int t=n;
        memset(path,0,sizeof(path));
        memset(vis,0,sizeof(vis));
        while(t--){
            scanf("%s",a);
            int len=strlen(a);
            for(int i=2;i<len;i++){
                path[a[0]-'A'][a[i]-'A']=1;
            }
        }
        ans=4;
        vis[0]=1;
        dfs(1);
        if(ans==1) printf("1 channel needed.\n");
        else printf("%d channels needed.\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值