POJ_2992_Divisors(组合数的因子数)

 Divisors
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Your task in this problem is to determine the number of divisors of  Cnk. Just for fun -- or do you need any special reason for such a useful computation?

Input

The input consists of several instances. Each instance consists of a single line containing two integers n and k (0 ≤ k ≤ n ≤ 431), separated by a single space.

Output

For each instance, output a line containing exactly one integer -- the number of distinct divisors of  Cnk. For the input instances, this number does not exceed 2 63 - 1.

Sample Input

5 1
6 3
10 4

Sample Output

2
6
16

题型数论


题意:题意很简单,就是求出 C(n,k).的因子有多少。

分析:设一个数n有cnt个约数,将n分解质因数,有

                                           n=p1^a1*p2^a2*p3^a3*···*pn^an

则约数个数为:

                                           cnt=(a1+1)*(a2+1)*(a3+1)*···*(an+1)

对于此题,每次输入数据后再算是不可取的,会导致TLE,所以我们要先来做一个预处理,我们先来看一下数据的范围,0 ≤ k ≤ n ≤ 431 ,范围不是很大,我们可以先筛出1~431的素数表,用cal(n,k)函数求出n!是能分解出多少个k,然后将数据存入数组c[ ][ ]中,c[ ][ ]中是什么呢?

c [ i ][ prime[ j ] ]=cal(n!, prime[i]) - cal((n - k)!, prime[i]) - cal(k!, prime[i])


代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
//83 primes
int prime[]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53,59,61,67,71,73,79,83,89,97,101,103,107,109,113,127,131,137,139,149,151,157,163,167,173,179,181,191,193,197,199,211,223,227,229,233,239,241,251,257,263,269,271,277,281,283,293,307,311,313,317,331,337,347,349,353,359,367,373,379,383,389,397,401,409,419,421,431};
int cal[500][500];

void fun(){
    int i,j,k,tem;
    for(i=0;i<500;i++){
        for(j=0;j<500;j++){
            cal[i][j]=0;
        }
    }

    for(k=1;k<=431;k++){
        for(i=1;i<=k;i++){
            tem=i;
            for(j=0;j<83;j++){
                while(tem%prime[j]==0){
                    tem/=prime[j];
                    cal[k][prime[j]]++;
                }
            }
        }
    }

}

int main(){
    int n,k,i;
    fun();
    while(~scanf("%d%d",&n,&k)){
        long long ans=1;
        for(i=0;i<=n;i++){
            int h=cal[n][i]-cal[k][i]-cal[n-k][i];
            ans*=(long long)(h+1);
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值