poj_2262_Goldbach's Conjecture(哥德巴赫猜想)

Goldbach's Conjecture
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34094 Accepted: 13068

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source


题型:数论


题意:

        哥德巴赫猜想,将一个数分解为两个素数,并且两个素数的差要最大,如果找不到这样的两个素数输出"Goldbach's conjecture is wrong."


分析:

       水题一枚。

       哥德巴赫猜想到现在还木有被证明出来,也就是说,到现在还木有反例来说它是错的,所以找不到是不可能的,这一步就不用判断了。。。

       两个素数的差要最大哦,那么就从头开始找或者从尾还是找,这样的话找到的第一对素数就是满足条件的数。

       用Eratosthenes筛法筛素数


代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
bool x[1234567];
void isprime(){
    memset(x,1,sizeof(x));
    x[0]=0;
    x[1]=0;
    for(int i=2;i*i<=1234567+1;i++){
        if(!x[i]) continue;
        for(int j=(i<<1);j<=1234567;j+=i){
            x[j]=0;
        }
    }
}

int main(){
    isprime();
    int n;
    while(scanf("%d",&n)&&n){
        int flag=0;
        for(int i=n;i>=3;i--){
            if(x[i]&&x[n-i]){
                printf("%d = %d + %d\n",n,n-i,i);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值