hdu1856More is better基础并查集

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 11685    Accepted Submission(s): 4325


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.



题意:和那个统计有几个集合的并查集差不多,这次不是统计有几个集合,而是每个集合里面有几个元素,并输出最大的一个集合的元素的个数。


思路:并查集合并认识的朋友,并且把 b 集合里的元素总数加到 a集合里面,然后比出最大的集合里的元素。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int LEN=10000050;
int fa[LEN], vis[LEN];
int find_fa(int a)//查找集合的首,就是寻找根节点
{
    return fa[a]==a ? a : fa[a]=find_fa(fa[a]);
}
//合并集合并且统计集合元素
void mergee(const int& a, const int& b)
{
    int pa=find_fa(a);
    int pb=find_fa(b);
    if( pa!=pb )
    {
        fa[pb]=pa;
        vis[pa]+=vis[pb];
    }
}
int main()
{
    int n, a, b, i, j, max, temp, fri;
    while( cin>>n )
    {
        if( n==0 )//特殊情况
        {
            cout<<"1\n";
            continue;
        }
        fri=-1;
        for(i=1; i<LEN; i++)//初始化
            fa[i]=i, vis[i]=1;//每个集合的根节点初始化为自己,每个集合元素个数为1
        for(i=1; i<=n; i++)
        {
            scanf("%d%d", &a, &b);
            if( fri<a ) fri=a;
            if( fri<b ) fri=b;
            mergee(a, b);
        }
        max=-1;
        for(i=1; i<=fri; i++)//比较出最大的集合的元素个数
        {
            if( max<vis[i] ) max=vis[i];
        }
        cout<<max<<endl;
    }
}












  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值