Problem Description
Recently, iSea went to an ancient country. For such a long time, it wasthe most wealthy and powerful kingdom in the world. As a result, the people inthis country are still very proud even if their nation hasn’t been so wealthyany more.
The merchants were the most typical, each of them only sold exactly oneitem, the price was Pi, but they would refuse to make a trade with you if yourmoney were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
Input
There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Output
For each test case, output one integer, indicating maximum value iSeacould get.
Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3
Sample Output
5
11
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=550;
struct Node
{
int p,q,v;
}node[maxn];
int dp[5500];
bool cmp(Node a,Node b)
{
return a.q-a.p<b.q-b.p;
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%d%d%d",&node[i].p,&node[i].q,&node[i].v);
sort(node,node+n,cmp);
memset(dp,0,sizeof(dp));
for(int i=0;i<n;i++)
for(int j=m;j>=node[i].q;j--)
dp[j]=max(dp[j],dp[j-node[i].p]+node[i].v);
printf("%d\n",dp[m]);
}
return 0;
}
按照q-p从小到大排序,然后0-1背包
至于按照q-p从小到大排序比较难想 。q-p其实就是不更新的范围,不更新的范围从小到大递增后就不会影响后边的DP了